Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009224 [DCSS] Bug Report major have not tried 2014-11-19 10:27 2015-03-04 03:24
Reporter TAS2012 View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009224: teleporting out of LOS of mesmerizer (siren) does not remove mesmerized status
Description
Character was mesmerized by a siren, teleported away, no monsters are in LOS, Mesm status is still active and character can't move away from (unseen) source.

_The merfolk hits you but does no damage.
 You cannot move away from the siren!
 You feel much better.
 Your surroundings suddenly seem different.
_You hear a luring song.
 You cannot move away from the siren!


·····?????·>·········?···?··??·??·??????                              
        TAS2012 the Warrior
···???????···········?···?·····?????????                                      
Hill Orc of Beogh *****.
·(·???????········?????··??··???????????                                      HP: 66/1
45 (147)  ==========--------------
†··)?????????·····?????··????????????????                                     MP: 9/31   
       ======------------------
···???????????····?????·???·??o?????????··                                    AC: 20     
       Str: 21
···???????? ???····???···?????···?????????                                    EV:  7   
         Int: 12
····??????? ????·?????···???····o·?????··?                                    SH: 20 
           Dex: 16
····????????????????????????·????··????··??                                   XL: 15 Next: 
52%  Place: Shoals:4
····???????????????????????··?  ??··???????                                   Gold: 1502    
    Time: 27969.2 (0.0)
····??????···?????????????···?  ?···?·?????                                   Wp: p) +
4 hand axe "Wobbotuf" {speed, rF+
····??????···?????????????·??????··???????                                    Qv: -) Nothi
ng quivered
····??????··??????????????·?  ?···????????                                    Mesm Water -
cTele
····?????????????????????··?  ?··??????????
····?????????????????????··?  ?··???????????
·····???????·%???·???????··????··????????????
······??????%%???·????????······?†???????????
·······??????????·????????·····??????????????
······P·????????··????????????????????????????
···P··PP·?((???···???????????????????@????????
········P········?????????????????????????????
············PP···P????????????????????·??????
·····???·····P··P??????????????PPP???·····???
?··??????·PPPPP???(????????????PP?P???P··????
??·???????P?PPPP???????????????P?P?P··??????
··??????????PP?????(··PP?????P···P?···?????
·??????P??P????????(·((PPP???······PP··P??
?·?????????????????)·(·····??··?    ···
???????????????????))()·······P?
?·????????????????·o·???·(·····???P
            ?????····? ?··(·o···(··
            ?????····???··(·?m·(P··
             ?··········??··mc··P·P
              ?··········?·o?m···P?
               ···········(cmP···c?
                  ···??···m<c·····?
                     ?······m···??
                   ··········?··??
 You hear a luring song.
 You cannot move away from the siren!


Maybe this is by design ("You hear a luring song"), but how can I even tell what/where I can not move away from when I don't see it anymore?

http://crawl.develz.org/saves/dumps/TAS2012-5684410-141119-0921.tar.bz2 [^]

Additional Information
Tags No tags attached.
Attached Files ? file icon 9224.patch [^] (1,029 bytes) 2015-03-02 16:31 [Show Content]

- Relationships
has duplicate 0006537resolvedwheals Mesmerise did not break when teleported out of mermaid LOS 
has duplicate 0008941resolvedwheals cannot move away from DEAD MONSTER 

-  Notes
(0027832)
TAS2012 (reporter)
2014-11-19 10:29
edited on: 2014-11-19 14:22

One more action and the status cleared:
 You break out of your daze!


Guess that makes it not so much a "major" bug really, but I still find it very confusing with the game telling me I can not move away from something I can not be sure where it is. Is this really by design?

(0028593)
ebering (developer)
2015-03-02 16:33

It wasn't by design, but it was somewhat subtle. Monster actions cause mesmerizers and fear mongers to be updated as well as player actions, but the update in player-reacts happens before you teleport, so possible strange things can happen with sequencing.

Attached patch should fix it (and anything else that could be related) but I can't actually download the save to test.
(0028600)
neil (administrator)
2015-03-04 03:24

ebering's patch is applied in trunk (0.17-a0-8-g6a7973e) and prerelease (0.16-b1-7-g437ab35), thanks.

- Issue History
Date Modified Username Field Change
2014-11-19 10:27 TAS2012 New Issue
2014-11-19 10:29 TAS2012 Note Added: 0027832
2014-11-19 14:22 TAS2012 Note Edited: 0027832
2015-03-02 16:31 ebering File Added: 9224.patch
2015-03-02 16:31 wheals Relationship added has duplicate 0006537
2015-03-02 16:32 wheals Relationship added has duplicate 0008941
2015-03-02 16:33 ebering Note Added: 0028593
2015-03-04 03:24 neil Note Added: 0028600
2015-03-04 03:24 neil Status new => resolved
2015-03-04 03:24 neil Fixed in Branch => 0.16 development branch
2015-03-04 03:24 neil Resolution open => done
2015-03-04 03:24 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker