Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009202 [DCSS] Patches minor have not tried 2014-11-17 03:15 2014-11-17 06:31
Reporter zuurr View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009202: Patch improving WebTiles rendering on HiDPI screens where possible
Description On HiDPI screens, the WebTiles canvas is scaled using CSS scaling, but since no image-rendering CSS property is provided for the canvas, it uses the browsers default, which tries to do fancy interpolation. This looks much worse than using nearest-neighbor (I'll attach before/after images after the patch).

Unfortunately, right now this can't be fixed (okay, it *might* be able to with much more work, but this will eventually work for them) in Chrome or Opera, as they don't yet respect the CSS `image-rendering` property (or, they do, but use an old interpretation of the spec that allows them to do nothing).

Anyway, I don't have access to a non-apple HiDPI screen, so I can't actually test this on windows or linux, other than to make sure it does nothing. That said, it works as advertised on Firefox and Safari, and will eventually work on Chrome and Opera once they get around to implementing the spec for `image-rendering` (or rather, once Blink does). I don't know if it works currently in IE, but it should.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Webtiles-Modify-styling-to-prevent-canvas-blurriness.patch [^] (1,165 bytes) 2014-11-17 03:15 [Show Content]
png file icon without-image-rendering-fix.png [^] (1,521,528 bytes) 2014-11-17 03:16
png file icon with-image-rendering-fix.png [^] (659,299 bytes) 2014-11-17 03:16
? file icon 0001-Webtiles-Modify-styling-to-prevent-canvas-blurriness-ammended.patch [^] (1,165 bytes) 2014-11-17 04:31 [Show Content]
? file icon 0001-Webtiles-Modify-styling-to-prevent-canvas-blurriness-ammended2.patch [^] (1,163 bytes) 2014-11-17 04:33 [Show Content]

- Relationships

-  Notes
(0027776)
sgrunt (administrator)
2014-11-17 03:25

Amusingly, I was working on something similar to this recently as I do have access to a high DPI device. I'll check this out shortly.
(0027781)
zuurr (reporter)
2014-11-17 04:29

Played a bit more with this active (since it's easy to paste into the style editor) and noticed that the images of the items when you view your inventory have the same problem, so I widened the scope of the selector to all canvases on the page.

Attaching an ammended patch.
(0027782)
sgrunt (administrator)
2014-11-17 04:32

There isn't a difference between your two patches - did you amend your commit properly?
(0027783)
zuurr (reporter)
2014-11-17 04:33

How embarrassing. Fixed.
(0027786)
sgrunt (administrator)
2014-11-17 06:31

Alright, this motivated me to get my own work on this front done; it was largely unrelated to your own tweak, which I landed at the same time as my own work as 0.16-a0-2349-gfa1ea45. Thank you!

- Issue History
Date Modified Username Field Change
2014-11-17 03:15 zuurr New Issue
2014-11-17 03:15 zuurr File Added: 0001-Webtiles-Modify-styling-to-prevent-canvas-blurriness.patch
2014-11-17 03:16 zuurr File Added: without-image-rendering-fix.png
2014-11-17 03:16 zuurr File Added: with-image-rendering-fix.png
2014-11-17 03:25 sgrunt Note Added: 0027776
2014-11-17 03:25 sgrunt Assigned To => sgrunt
2014-11-17 03:25 sgrunt Status new => assigned
2014-11-17 04:29 zuurr Note Added: 0027781
2014-11-17 04:31 zuurr File Added: 0001-Webtiles-Modify-styling-to-prevent-canvas-blurriness-ammended.patch
2014-11-17 04:32 sgrunt Note Added: 0027782
2014-11-17 04:33 zuurr File Added: 0001-Webtiles-Modify-styling-to-prevent-canvas-blurriness-ammended2.patch
2014-11-17 04:33 zuurr Note Added: 0027783
2014-11-17 06:31 sgrunt Note Added: 0027786
2014-11-17 06:31 sgrunt Status assigned => resolved
2014-11-17 06:31 sgrunt Resolution open => done
2014-11-17 06:31 sgrunt Product Branch experimental branch => 0.16 development branch
2014-11-17 06:31 sgrunt Fixed in Branch => 0.16 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker