Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009195 [DCSS] Bug Report minor have not tried 2014-11-14 04:44 2015-05-04 18:06
Reporter 78291 View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009195: Duplicate shop appears on ctrl-f 'shop'
Description Searching for 'shop' shows five results, but two of them are duplicates of shops already on the list.

Save: crawl.beRotato.org/crawl/saves/splat-crawl-git-7e03aa0adb-141114-0340.tar.bz2
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0009288resolvedPleasingFungus Ctrl-F "shop" buggy 

-  Notes
(0027758)
PleasingFungus (administrator)
2014-11-14 04:48

N.b. that this is almost certainly the result of gozag call merchant oddness.
(0027760)
nagdon (reporter)
2014-11-16 13:01

I also got duplicate shops in Ctrl+F shop without Gozag on a DDEE of Ru. Some (but not all) shops were duplicated, one copy displayed the real shop contents, the other was empty. My guess is that this could be caused by the passive mapping of deep dwarfs (or in the other case the funded shop detection of Gozag).
(0027770)
evktalo (administrator)
2014-11-16 22:16

http://crawl.develz.org/saves/dumps/Keskitalo-566df74-141116-2106.tar.bz2 [^]

Another save, no Gozag, no Deep Dwarf/mapping here. *might* have read ?mapping on the same level as the shop but I'm pretty sure it was a level earlier.
(0029004)
neil (administrator)
2015-05-04 18:06

Should be fixed in trunk (0.17-a0-919-g47d84a0). I want a little more testing before cherry-picking into stable.

- Issue History
Date Modified Username Field Change
2014-11-14 04:44 78291 New Issue
2014-11-14 04:48 PleasingFungus Note Added: 0027758
2014-11-16 13:01 nagdon Note Added: 0027760
2014-11-16 22:16 evktalo Note Added: 0027770
2014-12-02 17:16 PleasingFungus Relationship added has duplicate 0009288
2015-05-04 18:06 neil Note Added: 0029004
2015-05-04 18:06 neil Status new => resolved
2015-05-04 18:06 neil Fixed in Branch => 0.17 development branch
2015-05-04 18:06 neil Resolution open => done
2015-05-04 18:06 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker