Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009168 [DCSS] Bug Report crash always 2014-11-10 08:01 2014-11-10 12:19
Reporter Mattybee View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009168: Game crashes on killing brown very ugly thing
Description My current save on CSZO will immediately crash the moment I kill the brown very ugly thing to the north.

Crash dumps are here:

http://dobrazupa.org/morgue/Mattybee/crash-Mattybee-20141110-063941.txt [^]
http://dobrazupa.org/morgue/Mattybee/crash-Mattybee-20141110-064021.txt [^]
http://dobrazupa.org/morgue/Mattybee/crash-Mattybee-20141110-064515.txt [^]
http://dobrazupa.org/morgue/Mattybee/crash-Mattybee-20141110-065835.txt [^]

ASSERT(colour) in 'items.cc' at line 3826 failed.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027707)
Sphara (reporter)
2014-11-10 08:37

Noticed the same playing on CXC trunk,

http://crawl.xtahua.com/crawl/morgue/Sphara/crash-Sphara-20141110-065133.txt [^]

http://crawl.xtahua.com/crawl/morgue/Sphara/crash-Sphara-20141110-072147.txt [^]
(0027709)
thevogonpoet (reporter)
2014-11-10 09:01

Looks like I have the same problem on cdo:

http://crawl.develz.org/morgues/trunk/vogonpoet/crash-vogonpoet-20141110-075221.txt [^]
http://crawl.develz.org/morgues/trunk/vogonpoet/crash-recursive-vogonpoet-20141110-073031.txt [^]
(0027710)
starless (reporter)
2014-11-10 09:39

Yes, I have the same problem on CXC trunk:

http://crawl.xtahua.com/crawl/morgue/hackum/crash-hackum-20141110-083656.txt [^]
(0027711)
Ololoev (reporter)
2014-11-10 11:44
edited on: 2014-11-10 12:16

Same problem here. Game crash on killing:
1. Red very ugly thing (IOOD).
2. Green very ugly thing and red ugly thing simultaneously (Fireball).
3. Red ugly thing (IOOD).
4. 3 red ugly things simultaneously (Firestorm).
5. Red ugly thing (Iron shot).
6. Red ugly thing (Flame cloud).
7. Red ugly thing (Bolt of fire).

Ok on killing:
1. Red very ugly thing (Iron shot).
2. Red ugly thing (Firestorm).


http://dobrazupa.org/morgue/ololoev/crash-ololoev-20141110-072212.txt [^]
http://dobrazupa.org/morgue/ololoev/crash-ololoev-20141110-072504.txt [^]
http://dobrazupa.org/morgue/ololoev/crash-ololoev-20141110-072952.txt [^]
http://dobrazupa.org/morgue/ololoev/crash-ololoev-20141110-073017.txt [^]
... in http://dobrazupa.org/morgue/ololoev/ [^]

(0027712)
Medar (developer)
2014-11-10 12:19

Fixed by: http://s-z.org/neil/git/?p=crawl.git;a=commit;h=968ce0aafd3817dc12fc2b57ade0e561c3a4f94b [^] (gammafunk)

Most servers should be updated now.

- Issue History
Date Modified Username Field Change
2014-11-10 08:01 Mattybee New Issue
2014-11-10 08:37 Sphara Note Added: 0027707
2014-11-10 09:01 thevogonpoet Note Added: 0027709
2014-11-10 09:01 thevogonpoet Issue Monitored: thevogonpoet
2014-11-10 09:39 starless Note Added: 0027710
2014-11-10 11:44 Ololoev Note Added: 0027711
2014-11-10 11:51 Ololoev Issue Monitored: Ololoev
2014-11-10 12:02 Ololoev Note Edited: 0027711
2014-11-10 12:04 Ololoev Note Edited: 0027711
2014-11-10 12:16 Ololoev Note Edited: 0027711
2014-11-10 12:19 Medar Note Added: 0027712
2014-11-10 12:19 Medar Status new => resolved
2014-11-10 12:19 Medar Fixed in Branch => 0.16 development branch
2014-11-10 12:19 Medar Resolution open => done
2014-11-10 12:19 Medar Assigned To => Medar
2014-11-10 12:23 Ololoev Issue End Monitor: Ololoev
2014-11-10 19:03 thevogonpoet Issue End Monitor: thevogonpoet


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker