Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009166 [DCSS] Bug Report major always 2014-11-09 22:26 2014-11-10 06:16
Reporter TAS2012 View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009166: char_set=unicode option ignored
Description char_set=unicode setting in options is ignored in latest trunk on CDO. Standard

It is ignored in main Crawl as well as Sprint and Zot defence.

It works normally in 0.15 on CDO.

Savegame provided, but it actually shouldn't be needed, it affects new games just started as well, but just in case there is somethong wrong with my profile:
http://crawl.develz.org/saves/dumps/TAS2012-062c1af-141109-2125.tar.bz2 [^]

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027705)
wheals (administrator)
2014-11-10 00:20

The new way to do this is documented in http://s-z.org/neil/git/?p=crawl.git;a=commitdiff;h=d5cb7ae944ef. [^]
(0027706)
TAS2012 (reporter)
2014-11-10 06:16

Thanks for pointing this out to me. I should have read the (updated) options guide before posting here. So, include=old_unicode_glyphs.txt seems to mimic the old char_set=unicode behaviour.

However, it is still quite confusing to the user, or at least to me. Since the "new" unicode glyphs (really: char_set=default) do not use solid wall symbols or the · floor symbol, which was for me when testing this often the only thing I could see to differentiate between "unicode" and "ascii" I didn't see the char_set option switch doing anything at all and doubted its functionality. Analyzing this was made even more troublesome by the fact that even after adding the include line as above (changing the symbols to the old unicode style) the char_set setting was doing nothing. Perhaps the included lines override the char_set=ascii somehow?

Also, "old" in old_unicode_glyphs implies to me that this is some outdated, no longer to be updated, conservationist setting (further emphasized by moving the setting from standard options settings to using the lesser known include syntax) like the 0.xx_monster_glyphs settings. If this is really the case, perhaps it should be 0.15_unicode_glyphs for future clarity of what "old" is referred to.

For those who just want the old non-ascii walls/floor style but other glyphs being updated as Crawl development goes on (like what the non-ascii char_set settings used to do), the real way to mimic old behaviour seems to *not* be to use the include line as above but rather to replace their old char_set=foo with char_set=default and adding:
display_char = wall:?
display_char = permawall:?
display_char = wall_magic:?
display_char = floor:·
Otherwise they will be "frozen" in symbols development and, as an example, not getting the recent change of † as the corpse symbol.

I was trying to find some reason for switching to ascii-style walls/floor even in non-ascii mode, but couldn't find any. Could it be an oversight?

- Issue History
Date Modified Username Field Change
2014-11-09 22:26 TAS2012 New Issue
2014-11-10 00:20 wheals Note Added: 0027705
2014-11-10 00:20 wheals Status new => resolved
2014-11-10 00:20 wheals Fixed in Branch => 0.16 development branch
2014-11-10 00:20 wheals Resolution open => done
2014-11-10 00:20 wheals Assigned To => wheals
2014-11-10 06:16 TAS2012 Note Added: 0027706


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker