Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009160 [DCSS] Bug Report trivial N/A 2014-11-09 04:52 2014-11-09 06:06
Reporter silentsnack View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009160: Rod spells erroneously marked as 'useless'
Description Essentially harmless error, but potentially confusing or misleading.
Additional Information
Tags No tags attached.
Attached Files png file icon chop1.PNG [^] (44,784 bytes) 2014-11-09 04:52


png file icon chop2.PNG [^] (18,291 bytes) 2014-11-09 04:52


png file icon chop3.PNG [^] (3,063 bytes) 2014-11-09 04:52


gif file icon Rogga v.15.2-rod of ignition with enough MR.gif [^] (24,123 bytes) 2014-11-09 06:06

- Relationships

-  Notes
(0027698)
silentsnack (reporter)
2014-11-09 05:26

NB: the screenshot showing the rod with (4/10) charge was taken after firing it once, even though with (10/10) it was still grayed out with the 'useless' notation.
(0027699)
RoGGa (reporter)
2014-11-09 05:46

Interesting! The description on chop2.png definitely needs some updating since
according to the crawl_manual, Rods "...have a pool of magical energy which regenerates according to the rod's enchantment (which can be increased using scrolls of recharging) and your Evocations skill."
Therefore it doesn't use the player's MP (seen in chop3.PNG)...but the last line of the description on chop2.PNG makes it sound like it does.

As far as I know, Explosive Bolt is only available on Rods so it should be very simple to update it to a rod-specific description like:
"This spell cannot be used right now since the rod's magical reservoir has been depleted below what is required by this spell."
(0027700)
PleasingFungus (administrator)
2014-11-09 05:46

Wasn't able to reproduce the grey text for spell names (that always showed up blue for me), but the uselessness description should be fixed in 98bc2407866d. Let me know if that fixes things for you.
(0027701)
RoGGa (reporter)
2014-11-09 06:05
edited on: 2014-11-09 06:11

as for the greyed out part on chop2.png, I'm on v.15.2 (Linux Tiles) and it is not greyed out if the Rod has enough MR but it is when there isn't enough MP.
image attached: RoGGa v.15.2-rod of ignition with enough MR.gif)

Note: I got this info while in Wizard Mode and because of this the info for the spell was completely different than on chop2.png
My guess this might be a reason why silentsnack is getting different results.

Looking at the many occurrences of "Explosive Bolt" on http://crawl.develz.org/trunk/changes.txt, [^] it seems like it might be a recent meta-bug (a bug from a recent bug fix).


- Issue History
Date Modified Username Field Change
2014-11-09 04:52 silentsnack New Issue
2014-11-09 04:52 silentsnack File Added: chop1.PNG
2014-11-09 04:52 silentsnack File Added: chop2.PNG
2014-11-09 04:52 silentsnack File Added: chop3.PNG
2014-11-09 05:26 silentsnack Note Added: 0027698
2014-11-09 05:46 RoGGa Note Added: 0027699
2014-11-09 05:46 PleasingFungus Note Added: 0027700
2014-11-09 05:46 PleasingFungus Status new => resolved
2014-11-09 05:46 PleasingFungus Fixed in Branch => 0.16 development branch
2014-11-09 05:46 PleasingFungus Resolution open => done
2014-11-09 05:46 PleasingFungus Assigned To => PleasingFungus
2014-11-09 06:05 RoGGa Note Added: 0027701
2014-11-09 06:06 RoGGa File Added: Rogga v.15.2-rod of ignition with enough MR.gif
2014-11-09 06:11 RoGGa Note Edited: 0027701


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker