Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009159 [DCSS] Bug Report minor always 2014-11-09 00:30 2014-11-09 03:55
Reporter RoGGa View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0009159: entering WIZARD mode by accident
Description SCENARIOS
=========
1. When I press Ctrl-Q to quit the game, it asks me to confirm by typing: yes
So if I happened to press Ctrl-Q by accident, it would be unlikely that I could then type: yes ...followed by the Enter key and then wonder "what just happened?"

2. But, if I happen to press the & key by accident, all that is required to continue is to press: Y (without needing to press the Enter key)

2b. Also, it is possible that someone (with big or fingers) could inadvertently press (by complete accident at ~almost~ the same time) the & and Y keys since they are adjacent to one another.

If this were to happen, the player would be in *WIZARD* mode and would have no way of doing an Undo
...and if they happened to be very much invested in a character with a realistic hope of making it out of the Dungeon with the Orb, their score would not be saved.

I'm guessing this has not happened since I did not see it reported in the 1st 50 results when searching with "Wizard Mode" ...but it could happen to someone.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027691)
RoGGa (reporter)
2014-11-09 00:33

my suggestion for a solution is to require the player to type: yes
in the same way that is required to quit a game by using Ctrl-q
(0027693)
wheals (administrator)
2014-11-09 00:47

0.16-a0-1997-g24f5ed7 does so.
(0027695)
RoGGa (reporter)
2014-11-09 01:59

Oops...
I didn't see any reference to that when searching for "wizard mode" in http://crawl.develz.org/trunk/changes.txt [^]
(0027697)
PleasingFungus (administrator)
2014-11-09 03:55

That's because wheals made the change (in 0.16-a0-1997-g24f5ed7) in response to this ticket. :)

- Issue History
Date Modified Username Field Change
2014-11-09 00:30 RoGGa New Issue
2014-11-09 00:33 RoGGa Note Added: 0027691
2014-11-09 00:47 wheals Note Added: 0027693
2014-11-09 00:47 wheals Status new => resolved
2014-11-09 00:47 wheals Fixed in Branch => 0.16 development branch
2014-11-09 00:47 wheals Resolution open => done
2014-11-09 00:47 wheals Assigned To => wheals
2014-11-09 01:59 RoGGa Note Added: 0027695
2014-11-09 01:59 RoGGa Status resolved => closed
2014-11-09 03:55 PleasingFungus Note Added: 0027697


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker