Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009148 [DCSS] Bug Report minor always 2014-11-06 19:53 2014-11-28 18:40
Reporter foophykins View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch experimental branch
Summary 0009148: Can't load dump files at all
Description Saved a dump on CAO, can't load on CAO.
Took dump from CAO, can't load on windows/linux tiles or console.

Error happens when getting to items. No idea.

"Unknown Item: Warding. (no gloves)"
Have tried with a few characters over a while with trunk; Never ever works.
Attached dump.
Additional Information
Tags No tags attached.
Attached Files txt file icon foophykins.txt [^] (15,707 bytes) 2014-11-06 19:53 [Show Content]

- Relationships

-  Notes
(0027809)
foophykins (reporter)
2014-11-18 16:27

Now it comes up:

ASSERT(item.sub_type!= NUM_JEWELLERY) in 'wiz-dump.cc' at line 202 failed.

This then crashes crawl.
(0027813)
wheals (administrator)
2014-11-18 17:19

What version are you using? doy made some changes to the code.
(0027909)
foophykins (reporter)
2014-11-27 05:27

Now that the change has been made, a ring mail I was wearing was converted to a ring upon re-loading the dump file.
(0027915)
doy (developer)
2014-11-27 18:41

Can you try again with 0.16-a0-2810-gaef931b? In general, this code is pretty much solely intended as a debugging aid, and so I'm not incredibly interested in spending time making it very robust, but I would like to fix trivial issues like this that come up.
(0027926)
foophykins (reporter)
2014-11-28 18:34

Works now :)

- Issue History
Date Modified Username Field Change
2014-11-06 19:53 foophykins New Issue
2014-11-06 19:53 foophykins File Added: foophykins.txt
2014-11-18 16:27 foophykins Note Added: 0027809
2014-11-18 17:19 wheals Note Added: 0027813
2014-11-27 05:27 foophykins Note Added: 0027909
2014-11-27 18:41 doy Note Added: 0027915
2014-11-28 18:34 foophykins Note Added: 0027926
2014-11-28 18:40 PleasingFungus Status new => resolved
2014-11-28 18:40 PleasingFungus Fixed in Branch => 0.16 development branch
2014-11-28 18:40 PleasingFungus Resolution open => done
2014-11-28 18:40 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker