Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009096 [DCSS] Patches feature N/A 2014-10-28 02:24 2014-11-20 22:29
Reporter Sandman25 View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0009096: Zin recitation improvement
Description 2 improvements.
1) Recitation cannot be activated if all eligible monsters have too high HD.
2) Monster description displays how likely the monster to be affected by recitation (see screenshot).
Tested with different gods, piety, invocations and targets.

PS. I am not sure why my version says 0.15-a0-918-g656645e, I used branch "master".
Additional Information
Tags No tags attached.
Attached Files ? file icon recitation-description.patch [^] (4,428 bytes) 2014-10-28 02:24 [Show Content]
png file icon description_with_recitation.png [^] (21,306 bytes) 2014-10-28 02:26

- Relationships

-  Notes
(0027589)
Sandman25 (reporter)
2014-10-28 02:25
edited on: 2014-10-28 12:19

See https://crawl.develz.org/tavern/viewtopic.php?f=8&t=14013 [^] for discussion

Oops, I forgot to check eligibility for description. But it looks like it is impossible to determine eligibility without info leak: it depends on chaotic spells presence in actual spell slots and some monsters can have several spell sets. So I suggest to rename "Recitation effect" to "Recitation vs HD".

(0027713)
Sandman25 (reporter)
2014-11-10 14:20

Any comment why even first improvement cannot be incorporated into the game? Thank you
(0027829)
wheals (administrator)
2014-11-19 03:34

Reimplemented in http://s-z.org/neil/git/?p=crawl.git;a=commitdiff;h=ad397ecb1120 [^] and http://s-z.org/neil/git/?p=crawl.git;a=commitdiff;h=c26be3187d84. [^] Thanks for the code; while i rewrote most of it, the initial framework made it a lot easier for me to find what to change.
(0027852)
Sandman25 (reporter)
2014-11-20 22:29

Thank you!

- Issue History
Date Modified Username Field Change
2014-10-28 02:24 Sandman25 New Issue
2014-10-28 02:24 Sandman25 File Added: recitation-description.patch
2014-10-28 02:24 Sandman25 Note Added: 0027588
2014-10-28 02:25 Sandman25 Note Added: 0027589
2014-10-28 02:26 Sandman25 File Added: description_with_recitation.png
2014-10-28 12:02 Sandman25 Note Added: 0027591
2014-10-28 12:16 Sandman25 Note Added: 0027592
2014-10-28 12:17 Sandman25 Note Edited: 0027592
2014-10-28 12:18 Sandman25 Note Edited: 0027589
2014-10-28 12:18 Sandman25 Note Edited: 0027591
2014-10-28 12:18 Sandman25 Note Edited: 0027589
2014-10-28 12:18 Sandman25 Note Deleted: 0027588
2014-10-28 12:18 Sandman25 Note Deleted: 0027591
2014-10-28 12:18 Sandman25 Note Deleted: 0027592
2014-10-28 12:19 Sandman25 Note Edited: 0027589
2014-11-10 14:20 Sandman25 Note Added: 0027713
2014-11-19 03:34 wheals Note Added: 0027829
2014-11-19 03:34 wheals Status new => resolved
2014-11-19 03:34 wheals Fixed in Branch => 0.16 development branch
2014-11-19 03:34 wheals Resolution open => done
2014-11-19 03:34 wheals Assigned To => wheals
2014-11-20 22:29 Sandman25 Note Added: 0027852
2014-11-20 22:29 Sandman25 Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker