Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009087 [DCSS] Bug Report trivial always 2014-10-26 19:33 2015-10-19 23:00
Reporter RoGGa View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0009087: in Wizard Mode, the fight simulator doesn't report anyything for +0 hand axe
Description You are now empty-handed.
Enter Wizard Command (? - help):
Select a monster, or hit Escape to use default.
Press: ? - help, Shift-Dir - straight line, f - kobold
Aim: a kobold
           AvHitDam | MaxDam | Accuracy | AvDam | AvTime | AvSpeed | AvEffDam
Attacking: 2.8 | 8 | 50% | 1.4 | 99 | 1.01 | 1.4
Defending: 1.0 | 4 | 47% | 0.5 | 100 | 1.00 | 0.5
a - a +0 hand axe (weapon)
Enter Wizard Command (? - help):
Select a monster, or hit Escape to use default.
Press: ? - help, Shift-Dir - straight line, f - you, p - kobold
           AvHitDam | MaxDam | Accuracy | AvDam | AvTime | AvSpeed | AvEffDam
Attacking:
Defending:
i - a +0 club (weapon)
Enter Wizard Command (? - help):
Select a monster, or hit Escape to use default.
Press: ? - help, Shift-Dir - straight line, f - you, p - kobold
           AvHitDam | MaxDam | Accuracy | AvDam | AvTime | AvSpeed | AvEffDam
Attacking: 1.7 | 5 | 53% | 0.9 | 125 | 0.80 | 0.7
Defending: 1.0 | 4 | 47% | 0.5 | 100 | 1.00 | 0.5
Saving game... please wait.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027586)
RoGGa (reporter)
2014-10-27 18:49

How do I make a modification to my own bug report?
I'm guessing that, as a issue/bug "reporter", I don't have that right.

Here's additional info:
Since filing this trivial issue, I have continued to use the fight simulator and the following fields in this issue report should be changed:

   Reproducibility: sometimes (frequency on my old netbook: Note: 0000010-20%)
   Priority: low

...since getting blank lines as part of the fsim report is not specific to the +0 hand axe or to the &f (Quick simulation) since it has been happening more often with the &F (Simple scale simulation).

I am using a slow & old netbook with Xubuntu 14.04 whenever I play crawl-tiles locally so I don't know if that is part of the issue. I am getting blank lines 10%-20% of the time when using fsim's &f or &F.
The workaround that I have been using is to just rerun the fsim scenario until all the results that I'm looking for show up.

with &F, this can sometimes require running it 2-4 times since I can get something like the following results:

    Armour | AvHitDam | MaxDam | Accuracy | AvDam | AvTime | AvSpeed | AvEffDam
         0 | 0.7 | 4 | 54% | 0.4 | 100 | 1.00 | 0.4
         1 |
         2 |
         3 | 0.7 | 4 | 54% | 0.4 | 100 | 1.00 | 0.4
    ...

followed by:
    Armour | AvHitDam | MaxDam | Accuracy | AvDam | AvTime | AvSpeed | AvEffDam
         0 |
         1 | 0.6 | 4 | 56% | 0.3 | 100 | 1.00 | 0.3
         2 |
         3 | 0.7 | 4 | 54% | 0.4 | 100 | 1.00 | 0.4
    ...

Let me know if additional info/scenarios could help.
Rob :-)
(0028254)
neil (administrator)
2015-01-08 22:36

This should be fixed in trunk. It appears to have been a dangling pointer to freed data, that sometimes happened to be overwritten with zero but usually managed not to be.

- Issue History
Date Modified Username Field Change
2014-10-26 19:33 RoGGa New Issue
2014-10-27 02:58 RoGGa Issue Monitored: RoGGa
2014-10-27 18:49 RoGGa Note Added: 0027586
2014-11-11 02:55 RoGGa Issue End Monitor: RoGGa
2015-01-08 22:36 neil Note Added: 0028254
2015-01-08 22:36 neil Status new => resolved
2015-01-08 22:36 neil Fixed in Branch => 0.16 development branch
2015-01-08 22:36 neil Resolution open => done
2015-01-08 22:36 neil Assigned To => neil
2015-10-19 23:00 RoGGa Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker