Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009086 [DCSS] Bug Report text have not tried 2014-10-26 19:20 2014-10-26 19:47
Reporter Kadarus View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009086: Incorrect delay description for sling
Description While you are wielding a sling, if you press @, the delay description appears incorrectly. For example, it displays "Your attack speed is quite slow." for 0.6 delay.
Save: https://dobrazupa.org/saves/Kadarus-crawl-git-cf82e137c1-141026-1819.tar.bz2 [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027573)
PleasingFungus (administrator)
2014-10-26 19:27

This is because it's displaying your melee attack delay for the weapon, since you don't have any ammo of the appropriate type currently quivered.

The relevant function (_display_attack_delay()) has a comment reading: "XXX fix this".
(0027574)
Kadarus (reporter)
2014-10-26 19:29
edited on: 2014-10-26 19:30

But I have sling bullets quivered in that save and it still displays "quite slow".

(0027575)
PleasingFungus (administrator)
2014-10-26 19:30

Oh, right. Slings are weird.

I'll poke at it.
(0027576)
PleasingFungus (administrator)
2014-10-26 19:47

OK, the sling bullet silliness should be fixed in cee5fc8.

- Issue History
Date Modified Username Field Change
2014-10-26 19:20 Kadarus New Issue
2014-10-26 19:27 PleasingFungus Note Added: 0027573
2014-10-26 19:29 Kadarus Note Added: 0027574
2014-10-26 19:30 Kadarus Note Edited: 0027574
2014-10-26 19:30 PleasingFungus Note Added: 0027575
2014-10-26 19:47 PleasingFungus Note Added: 0027576
2014-10-26 19:47 PleasingFungus Status new => resolved
2014-10-26 19:47 PleasingFungus Fixed in Branch => 0.16 development branch
2014-10-26 19:47 PleasingFungus Resolution open => done
2014-10-26 19:47 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker