Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009052 [DCSS] Patches minor have not tried 2014-10-16 01:21 2014-10-28 21:58
Reporter chequers View Status public  
Assigned To edlothiol
Priority normal Resolution done  
Status resolved   Product Branch experimental branch
Summary 0009052: [PATCH] webserver: Add support for -dir
Description This patch adds support for specifying -dir arg with the tiles webserver. This allows you to specify a save/cachedir at runtime, rather than needing to compiled with a specific SAVEDIR.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-webtiles-Add-support-for-dir.patch [^] (3,020 bytes) 2014-10-16 01:21 [Show Content]
? file icon v2-0001-webtiles-Add-support-for-dir.patch [^] (2,312 bytes) 2014-10-16 02:24 [Show Content]
? file icon 0001-webtiles-changes-Add-support-for-dir.patch [^] (1,983 bytes) 2014-10-17 03:53 [Show Content]

- Relationships

-  Notes
(0027499)
chequers (reporter)
2014-10-16 02:24

Updated patch:
v2-0001-webtiles-Add-support-for-dir.patch

dir_path is optional, and unset by default. When unset, -dir is not added to crawl commandline. This preserves config file backwards compatibility.
(0027501)
chequers (reporter)
2014-10-17 03:53

Added patch:
0001-webtiles-changes-Add-support-for-dir.patch

This is the same patch but for the webtiles-changes branch. I'm hoping you can merge the current patch now and this one into the pending TOML update.
(0027503)
edlothiol (developer)
2014-10-18 01:01

Pushed the webtiles-changes version. I'd prefer not merging the other patch though, since it'd just lead to more conflicts when we merge webtiles-changes. Could you either start using webtiles-changes now (I consider it ready for testing on the servers, it's just waiting on the necessary server script changes), or apply the patch locally (it's unlikely there will be more webtiles changes before the branch is merged)?
(0027513)
chequers (reporter)
2014-10-21 02:06

Actually, the commits only differ in their modifications to the example config files so there should be no additional merge work!
(0027533)
edlothiol (developer)
2014-10-22 13:02

I'll merge the patch if it's so important to you, but you have to understand that trunk webtiles is a dead end. I'm only working on the branch, and I'm just waiting for the servers to switch so I can merge it (and every new server that uses trunk just makes that harder).

Note that I'm just talking about the server and non-version-specific client code; you can (and are intended to) run trunk Crawl with the webtiles-changes server. The fact that the official servers currently hardcode the server to run from trunk is part of why this has taken so long to merge; if you are making a new official server from scratch, I'd prefer if you are prepared to switch branches for the server independently.

(I don't know how much you know about running multiple Crawl versions in webtiles; in short, the contents of webserver/game_data are specific to each Crawl version, and the python code and contents of webserver/static are shared.)
(0027596)
chequers (reporter)
2014-10-28 21:06

Thanks! This issue can be closed, as you suggested I'm using webtiles-changes now :)
(0027599)
edlothiol (developer)
2014-10-28 21:58

OK, great!

- Issue History
Date Modified Username Field Change
2014-10-16 01:21 chequers New Issue
2014-10-16 01:21 chequers File Added: 0001-webtiles-Add-support-for-dir.patch
2014-10-16 02:24 chequers File Added: v2-0001-webtiles-Add-support-for-dir.patch
2014-10-16 02:24 chequers Note Added: 0027499
2014-10-17 03:53 chequers File Added: 0001-webtiles-changes-Add-support-for-dir.patch
2014-10-17 03:53 chequers Note Added: 0027501
2014-10-18 01:01 edlothiol Note Added: 0027503
2014-10-21 02:06 chequers Note Added: 0027513
2014-10-22 13:02 edlothiol Note Added: 0027533
2014-10-28 21:06 chequers Note Added: 0027596
2014-10-28 21:58 edlothiol Note Added: 0027599
2014-10-28 21:58 edlothiol Status new => resolved
2014-10-28 21:58 edlothiol Fixed in Branch => experimental branch
2014-10-28 21:58 edlothiol Resolution open => done
2014-10-28 21:58 edlothiol Assigned To => edlothiol


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker