Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009048 [DCSS] Bug Report minor always 2014-10-14 13:20 2014-10-14 22:55
Reporter nago View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0009048: Game crash when killing an enemy carrying one type of unidentified rod
Description My current game crashed twice, in two different situations(elf:3 and V:5) after I've killed an enemy carrying an unidentified rod, with the message "unknown rod type"
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027490)
wheals (administrator)
2014-10-14 17:35

Could you post a crash log? If you're on Windows it might not be too useful, but could help a little. If you still have the save from before you killed the monster that might help too.
(0027491)
nago (reporter)
2014-10-14 19:00
edited on: 2014-10-14 21:42

Unfortunately, I cannot: I was playing on crawl.s-z.org via webtiles, all I had was that message.

edit: also my current game crashes on Lair 1 for the same reason: "unknown rod type 10"
Is anything I can do with this one to provide more informations?

(0027494)
neil (administrator)
2014-10-14 22:55

Fixed in trunk (0.16-a0-1299-g7f81556), thanks!

The crash log wasn't linked, and the milestone wasn't generated, because the game crashed (from the same bug) while writing the crash dump (what the game calls a "recursive crash"). The crash logs are there in your morgue dir; for example, one of the crashes and the associated recursive crash:

  http://dobrazupa.org/morgue/nago/crash-nago-20141014-103318.txt [^]
  http://dobrazupa.org/morgue/nago/crash-recursive-nago-20141014-103320.txt [^]

- Issue History
Date Modified Username Field Change
2014-10-14 13:20 nago New Issue
2014-10-14 17:35 wheals Note Added: 0027490
2014-10-14 19:00 nago Note Added: 0027491
2014-10-14 21:42 nago Note Edited: 0027491
2014-10-14 22:55 neil Note Added: 0027494
2014-10-14 22:55 neil Status new => resolved
2014-10-14 22:55 neil Fixed in Branch => 0.16 development branch
2014-10-14 22:55 neil Resolution open => done
2014-10-14 22:55 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker