Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0009019 [DCSS] Bug Report minor have not tried 2014-10-04 22:13 2015-01-30 18:20
Reporter MarvinPA View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0009019: Player is placed on top of a monster in Ziggurats
Description When entering a Zig floor that has been completely filled with monsters, a monster can be placed on the entry square resulting in the player and a monster existing on the same square.

http://crawl.develz.org/saves/dumps/MarvinPA-0a3dd61-141004-2011.tar.bz2 [^]
Additional Information
Tags No tags attached.
Attached Files ? file icon Sarilsa.cs [^] (2,688,241 bytes) 2014-11-23 01:59
txt file icon crash-Sarilsa-20141123-014908.txt [^] (41,688 bytes) 2014-11-23 01:59 [Show Content]

- Relationships
related to 0008990resolvedPleasingFungus autofight broke on a filled up early zig floor 
has duplicate 0009103resolvedPleasingFungus More Ziggurat Problems 

-  Notes
(0027434)
MarvinPA (developer)
2014-10-04 22:13

0008990 looks related since that Lua error is what I see when trying to autofight the mummy priest that is on my square.
(0027608)
PleasingFungus (administrator)
2014-10-30 05:55

Fixed in 83ee05f.
(0027884)
Galefury (updater)
2014-11-23 01:58

It happened again, on one of those floors where you're placed in the middle. Save and crash report attached.
(0027885)
PleasingFungus (administrator)
2014-11-23 05:17

I wasn't able to reproduce, but this *should* still be fixed in d333f3b. Reopen if it happens in a later version.

- Issue History
Date Modified Username Field Change
2014-10-04 22:13 MarvinPA New Issue
2014-10-04 22:13 MarvinPA Note Added: 0027434
2014-10-04 22:14 MarvinPA Relationship added related to 0008990
2014-10-29 18:16 PleasingFungus Relationship added has duplicate 0009103
2014-10-30 05:55 PleasingFungus Note Added: 0027608
2014-10-30 05:55 PleasingFungus Status new => resolved
2014-10-30 05:55 PleasingFungus Fixed in Branch => 0.16 development branch
2014-10-30 05:55 PleasingFungus Resolution open => done
2014-10-30 05:55 PleasingFungus Assigned To => PleasingFungus
2014-11-23 01:58 Galefury Note Added: 0027884
2014-11-23 01:58 Galefury Status resolved => new
2014-11-23 01:58 Galefury Resolution done => reopened
2014-11-23 01:59 Galefury File Added: Sarilsa.cs
2014-11-23 01:59 Galefury File Added: crash-Sarilsa-20141123-014908.txt
2014-11-23 05:17 PleasingFungus Note Added: 0027885
2014-11-23 05:17 PleasingFungus Status new => resolved
2014-11-23 05:17 PleasingFungus Resolution reopened => done
2015-01-30 18:20 MarvinPA Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker