Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008984 [DCSS] Bug Report crash always 2014-09-23 02:07 2014-10-07 03:58
Reporter araganzar View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0008984: Crashing on game start
Description Went downstairs from Elf1 to Elf2 and game crashed. Game now crashes every time on re-entry. Displays splash screen then "Unfortunately your game ended unexpectedly".
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027349)
araganzar (reporter)
2014-09-23 19:33

This time when starting I was given option to update to new version and applied. After that crashed on load with same message.

This is on Trunk at http://crawl.akrasiac.org:8080/#lobby [^]
(0027350)
PleasingFungus (administrator)
2014-09-23 20:37

Can you dump your save (through the console interface) and post the link here?
(0027351)
araganzar (reporter)
2014-09-23 21:11

Older game but was working fine before entry into Elf 2. Suspect maybe trying to place Blades? Crashes on console entry so cannot generate dump. Here is what I have:

We crashed! This is likely due to a bug in Crawl. Please submit a bug report at https://crawl.develz.org/mantis/ [^] and include the crash report (/dgldir/ttyrec/araganzar/crash-araganzar-20140923-185935.txt), your save file (/crawl-master/crawl-git-bafcc93dc4/saves/araganzar.cs), and a description of what you were doing when this crash occurred.

Backing up: successful.
- http://crawl.akrasiac.org/saves/araganzar-crawl-git-bafcc93dc4-140923-1504.tar.bz2 [^]

Latest dump I can find before crash is at: http://crawl.akrasiac.org/rawdata/araganzar/araganzar.txt [^]

Found a crash dump at:
http://crawl.akrasiac.org/rawdata/araganzar/crash-araganzar-20140923-190444.txt [^]
(0027378)
araganzar (reporter)
2014-09-29 13:26

According to PF it's locked until the map code is fixed or someone removes the save game to make CAO trunk available again.

The game is crashing trying many times to place Hall of Blades in Elf2 as I had never entered Elf2 prior and this is an older game. This may be a problem for other old games, don't know if it's worth fixing or not.
(0027449)
neil (administrator)
2014-10-07 03:57

Fixed in trunk (0.16-a0-1141-gc630e73), thanks! You should be able to pick up on Elf:2. The problem was that the new Elven Hall of Blades didn't properly handle games that already had Blade.

- Issue History
Date Modified Username Field Change
2014-09-23 02:07 araganzar New Issue
2014-09-23 19:33 araganzar Note Added: 0027349
2014-09-23 20:37 PleasingFungus Note Added: 0027350
2014-09-23 21:11 araganzar Note Added: 0027351
2014-09-29 13:26 araganzar Note Added: 0027378
2014-10-07 03:57 neil Note Added: 0027449
2014-10-07 03:57 neil Status new => resolved
2014-10-07 03:57 neil Fixed in Branch => 0.16 development branch
2014-10-07 03:57 neil Resolution open => done
2014-10-07 03:57 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker