Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008967 [DCSS] Bug Report minor always 2014-09-16 23:22 2014-09-28 17:25
Reporter CommanderC View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0008967: Confusing change to Confusing Touch
Description The description for the commit 7a813ab0 says: "make the first successful (confusing) hit end the effect", but this is not what the code actually does, and it can easily be confirmed by using the spell.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027319)
neil (administrator)
2014-09-20 16:06

I can't reproduce this: "The ogre appears confused. Your tentacles stop glowing." even when the attack took only 0.5 game turns.

The code sets the duration to 1 rather than zero so you get the "stop glowing" message.
(0027321)
CommanderC (reporter)
2014-09-20 23:36

Sorry, I didn't explain myself properly. The duration is always set to 1, even when the confusion roll failed. This makes the new version of the spell strictly weaker than the old one, and (what is more important) more tedious to use.
 Your hands begin to glow red. The killer bee closely misses you.
_The killer bee stings you but does no damage.
 You hit the killer bee but do no damage.
 Your hands stop glowing.
 The killer bee barely misses you. The killer bee misses you.
(0027362)
PleasingFungus (administrator)
2014-09-28 17:25

Should be fixed in e6c3fc3, thanks!

- Issue History
Date Modified Username Field Change
2014-09-16 23:22 CommanderC New Issue
2014-09-20 16:06 neil Note Added: 0027319
2014-09-20 23:36 CommanderC Note Added: 0027321
2014-09-28 17:25 PleasingFungus Note Added: 0027362
2014-09-28 17:25 PleasingFungus Status new => resolved
2014-09-28 17:25 PleasingFungus Fixed in Branch => 0.16 development branch
2014-09-28 17:25 PleasingFungus Resolution open => done
2014-09-28 17:25 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker