Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008959 [DCSS] Bug Report major always 2014-09-15 09:13 2014-09-15 10:17
Reporter Mattybee View Status public  
Assigned To doy
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0008959: All monsters hypersensitive to noise
Description All monsters appear to be hypersensitive to anything that generates noise now. I've tested this with various characters going through early dungeons - spells that shouldn't be generating lots of noise (e.g. Sting or Sandblast) are waking up huge swathes of monsters:

The sting hits the rat! The rat is poisoned!
You annihilate the rat!!!
You hear a shout!!! x4
You hear a bark!!! x4
You hear a shout!!! x2

A giant newt comes into view!
The giant newt bites you!
You hear a shout!!!
You hear a bark!!!
You hear a shout!!!
You hear a bark!!!
You hear a bark!!!
You hear a shout!!

The blast of sand hits the bat!
You annihilate the bat!!!
You hear a shout!!! (6x)

I had some other people in ##crawl test it too - it definitely seems like everything just wakes up the moment you do anything noisy at all!
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027256)
sim (reporter)
2014-09-15 09:14
edited on: 2014-09-15 09:17

<simmarine> You shoot an arrow of frost.
<simmarine> _You hear a shout! x7

 You claw the giant newt!
 You kill the giant newt!
_You hear a shout! x7

just confirming that this is not exclusive to spells and seems to be a general thing with noise.

(0027257)
Bloax (reporter)
2014-09-15 09:16

Sounds like you're casting shatter except you're not casting shatter.

maybe all the recent changes messed something up somewhere
(0027259)
doy (developer)
2014-09-15 10:17

Fixed in 0.16-a0-453-g64c6b9b.

- Issue History
Date Modified Username Field Change
2014-09-15 09:13 Mattybee New Issue
2014-09-15 09:14 sim Note Added: 0027256
2014-09-15 09:16 Bloax Note Added: 0027257
2014-09-15 09:17 sim Note Edited: 0027256
2014-09-15 10:17 doy Note Added: 0027259
2014-09-15 10:17 doy Status new => resolved
2014-09-15 10:17 doy Fixed in Branch => 0.16 development branch
2014-09-15 10:17 doy Resolution open => done
2014-09-15 10:17 doy Assigned To => doy


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker