Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008951 [DCSS] Bug Report text always 2014-09-13 01:16 2015-12-21 02:15
Reporter rchandra View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008951: Ely pacification on holies uses odd messages
Description When you use Elyvilon's pacification on holy mosnters, you get the old messages from worshipping a good god and having them become peaceful, many of which are a bit weird. Some are buggy, like

The angel says @to_foe@, "Forge ahead, servant of @foe_god@!"
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027220)
PleasingFungus (administrator)
2014-09-13 01:59

These messages were explicitly & intentionally left in at the time that holy pacification was removed; I don't know if we still want that behaviour, but it wasn't an oversight.

For what it's worth, I don't see anything wrong with the quoted message.
(0027310)
johnnyzero (reporter)
2014-09-19 12:22

I've also noticed this behavior while clearing holy pan worshiping Elyvilon. Most pacification messages printed fine, but sometimes a message like the one in the bug description sneaked through. Perhaps it's something to do with pacifying a distracted holy?
(0027311)
rchandra (reporter)
2014-09-19 18:50

The quoted message is a problem because the @to_foe@ etc are being shown to the user.
(0027429)
neil (administrator)
2014-10-04 08:38

Looks like it happens whenever the monster has no foe.
(0030037)
wheals (administrator)
2015-12-21 02:15

Fixed in https://github.com/crawl/crawl/commit/ef3a054b9468. [^]

- Issue History
Date Modified Username Field Change
2014-09-13 01:16 rchandra New Issue
2014-09-13 01:59 PleasingFungus Note Added: 0027220
2014-09-19 12:22 johnnyzero Note Added: 0027310
2014-09-19 18:50 rchandra Note Added: 0027311
2014-10-04 08:38 neil Note Added: 0027429
2015-12-21 02:15 wheals Note Added: 0030037
2015-12-21 02:15 wheals Status new => resolved
2015-12-21 02:15 wheals Fixed in Branch => 0.18 development branch
2015-12-21 02:15 wheals Resolution open => done
2015-12-21 02:15 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker