Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008947 [DCSS] Patches minor always 2014-09-11 09:20 2015-01-20 18:50
Reporter croikle View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0008947: Redraw EV when curing petrification
Description * The `petrifying` status reduces EV.
* Elyvilon's `Purification` cures this status.
* This changes your EV back, but it doesn't redraw immediately.

Attached a one-line patch which appears to fix this.

SH is also affected by this status, but it seems to be redrawn correctly. I don't see why this is the case; probably we should also set `redraw_armour_class` to be safe.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Redraw-EV-after-Elivilon-Purification.patch [^] (766 bytes) 2014-09-11 09:20 [Show Content]

- Relationships

-  Notes
(0027206)
PleasingFungus (administrator)
2014-09-11 17:29

Reproduced & pushed, thanks!
(0028322)
Sprucery (reporter)
2015-01-20 18:50
edited on: 2015-01-20 18:51

I noticed the same issue in 0.15 when I quaffed a potion of cancellation while turning to stone.


- Issue History
Date Modified Username Field Change
2014-09-11 09:20 croikle New Issue
2014-09-11 09:20 croikle File Added: 0001-Redraw-EV-after-Elivilon-Purification.patch
2014-09-11 17:29 PleasingFungus Note Added: 0027206
2014-09-11 17:29 PleasingFungus Status new => resolved
2014-09-11 17:29 PleasingFungus Fixed in Branch => 0.16 development branch
2014-09-11 17:29 PleasingFungus Resolution open => done
2014-09-11 17:29 PleasingFungus Assigned To => PleasingFungus
2015-01-20 18:50 Sprucery Note Added: 0028322
2015-01-20 18:51 Sprucery Note Edited: 0028322


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker