Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008928 [DCSS] Upload: Graphics trivial N/A 2014-09-06 04:57 2014-12-08 07:22
Reporter roctavian View Status public  
Assigned To
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0008928: New and tweaked tiles for several dreadful creatures
Description L-R

Shadow Demon, Tormentor, Flayed Ghost, Hellion

Kirke, Ice Beast

Vampire, Ynox, Sonja, Hellfire

---
Several of these are just cleanups, a couple are complete redraws. I added just a bit of glow around hellfire so it tiles nicer with 3x3 explosions, vampires can be shown with equipped weapons. Ynox are a little bit dimmer. Ice Beasts are altered to match their summon spell. See if you can detect the visual pun with the flayed ghost.
Additional Information
Tags No tags attached.
Attached Files png file icon sept.2014.monsters.png [^] (25,239 bytes) 2014-09-06 04:57


png file icon ice.hellion.kirke.png [^] (10,384 bytes) 2014-09-13 23:47

- Relationships

-  Notes
(0027158)
Reaver (developer)
2014-09-06 05:12

Just as a reminder: If the new ice beast tile gets in, the ice form-ed player tile should probably change too.
(0027175)
ontoclasm (developer)
2014-09-07 20:36

These look good. The hellion in particular is pretty cool, though I think I'd just fill in the space under his arms with pink, since currently it looks really busy against black. Aside from that, I think I'd put some stronger shadows on Kirke's dress and the ice beast's torso, but that's it.
(0027176)
roctavian (developer)
2014-09-08 19:26

I should be able to do a few of these edits today or tomorrow -- one of the reason there isn't much definition on the ice beast's body, however, is that I'm not sure how I want to define its shape. Probably something that makes it look craggier/icier, but not too much since it's an early-game monster after all.
(0027178)
ontoclasm (developer)
2014-09-09 04:24

Yeah, ice is tricky to draw convincingly. If it were me I'd try to suggest a dark blue core with strong, bright highlights and deep internal shadows; ice has facets and transparency and high gloss, so play on those.
(0027250)
roctavian (developer)
2014-09-13 23:48

I'm not 100% about this ice beast, but I'm pretty happy with most aspects of it.
(0028006)
roctavian (developer)
2014-12-08 07:22

Everything is in.

- Issue History
Date Modified Username Field Change
2014-09-06 04:57 roctavian New Issue
2014-09-06 04:57 roctavian File Added: sept.2014.monsters.png
2014-09-06 05:12 Reaver Note Added: 0027158
2014-09-07 20:36 ontoclasm Note Added: 0027175
2014-09-08 19:26 roctavian Note Added: 0027176
2014-09-09 04:24 ontoclasm Note Added: 0027178
2014-09-13 23:47 roctavian File Added: ice.hellion.kirke.png
2014-09-13 23:48 roctavian Note Added: 0027250
2014-12-08 07:22 roctavian Note Added: 0028006
2014-12-08 07:22 roctavian Status new => closed
2014-12-08 07:22 roctavian Resolution open => done
2014-12-08 07:22 roctavian Fixed in Branch => 0.16 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker