Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008865 [DCSS] Bug Report minor always 2014-08-12 04:05 2015-04-06 17:55
Reporter Vinterriket View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008865: Screen indicates rotten chunks can be eaten
Description If you hover the mouse cursor over a rotten chunk in your inventory or on the ground, the game indicates that it can be eaten when it cannot (see pic). Playing a Kobold if that matters.

Similar to Issue ID 0008618

I suppose this won't matter for chunkless
Additional Information
Tags No tags attached.
Attached Files png file icon yummy.png [^] (80,475 bytes) 2014-08-12 04:05


png file icon yummy2.png [^] (59,455 bytes) 2014-08-12 13:04

- Relationships

-  Notes
(0026977)
PleasingFungus (administrator)
2014-08-12 05:34

This seems to be the same as the 0.14 behaviour. What exactly do you expect to see here?
(0026979)
Vinterriket (reporter)
2014-08-12 13:03

I would expect that the little pop-up menu would not indicate that I can eat the rotten chunk when in actuality I can't eat it. (see 2nd pic)

Referencing issue ID 0008618, I reported that issue when corpses became stationary (unable to be picked up), the little pop-up menu indicated that I could in fact pick up the corpse. Neil's commit changed it so now if you hover the cursor over a corpse it simply has a one line description 'a goblin corpse' unless you have some other way of interacting with it.

Since rotten chunks can no longer be eaten, I think the same logic would follow in this case.
(0026980)
Vinterriket (reporter)
2014-08-12 15:18

Ah, I thought this was related to removing saprovorous. Just noticed when playing Tengu that it still says I can eat a rotten chunk when I actually can't.

So yea, I assume this is same behaviour as 0.14 ...but still seems like something that could be fixed. The menu shouldn't say I can eat something when I can't.
(0028781)
wheals (administrator)
2015-04-06 17:55

No such thing as rotting chunks anymore.

- Issue History
Date Modified Username Field Change
2014-08-12 04:05 Vinterriket New Issue
2014-08-12 04:05 Vinterriket File Added: yummy.png
2014-08-12 05:34 PleasingFungus Note Added: 0026977
2014-08-12 13:03 Vinterriket Note Added: 0026979
2014-08-12 13:04 Vinterriket File Added: yummy2.png
2014-08-12 15:18 Vinterriket Note Added: 0026980
2015-02-03 10:20 chris Issue Monitored: chris
2015-04-06 17:55 wheals Note Added: 0028781
2015-04-06 17:55 wheals Status new => resolved
2015-04-06 17:55 wheals Fixed in Branch => 0.16 pre-release branch
2015-04-06 17:55 wheals Resolution open => done
2015-04-06 17:55 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker