Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008857 [DCSS] Patches feature N/A 2014-08-08 05:29 2014-10-11 19:47
Reporter infiniplex View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008857: Place multiple doors along long walls
Description This patch allows multiple doors to place along long walls if they are far enough apart. It mostly applies to layout_onion_city (the Elf city layout which is staying disabled until 0.16), but also can affect layout_stronghold and layout_honeycomb.

You can now set the length along the walls to check for other doors. The default is 9999 (effectively the whole wall).

There is also a minor fix to allow cave tiles for layout_honeycomb in Depths (where it appears) instead of D (where it doesn't). This will probably have little in-game effect because layout_honeycomb is nearly always vetoed in Depths because of vault connectivity.

And I changed the "%i"s in the error message to "%d"s because "%d" works and "%i" doesn't. The fact that no one has noticed this in more than a year suggests the error never happens.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Improved-algorithm-to-place-multiple-doors-on-long-w.patch [^] (7,933 bytes) 2014-08-08 05:29 [Show Content]
? file icon 0001-Re-added-layout_onion_city-to-Elf-with-better-window.patch [^] (3,616 bytes) 2014-09-04 00:38 [Show Content]
png file icon onion-city-layouts-elf.png [^] (6,931 bytes) 2014-09-04 00:38

- Relationships

-  Notes
(0027145)
infiniplex (reporter)
2014-09-04 00:45
edited on: 2014-09-30 10:05

And here is the patch to add layout_onion_city back into Elf (which is what the doors were for). EDIT: The first patch is also used by 0008917 (oops!).

In this version:
  -> Rooms have multiple doors, but none too close together
  -> Windows may appear 2 cells along the wall from a door in either direction. They do not appear anywhere else (in the layout).
  -> Weight 10 instead of 20.
  -> Still places around primary vaults

The teal (dark cyan) spots on the map are the windows. There are not more sample images because they have to be added by hand and I am lazy.

(0027465)
gammafunk (administrator)
2014-10-11 19:47

Pushed in a batch as part of 0.16-a0-1211-ge393dcd, thanks!

- Issue History
Date Modified Username Field Change
2014-08-08 05:29 infiniplex New Issue
2014-08-08 05:29 infiniplex File Added: 0001-Improved-algorithm-to-place-multiple-doors-on-long-w.patch
2014-09-04 00:38 infiniplex File Added: 0001-Re-added-layout_onion_city-to-Elf-with-better-window.patch
2014-09-04 00:38 infiniplex File Added: onion-city-layouts-elf.png
2014-09-04 00:45 infiniplex Note Added: 0027145
2014-09-30 10:05 infiniplex Note Edited: 0027145
2014-10-11 19:47 gammafunk Note Added: 0027465
2014-10-11 19:47 gammafunk Status new => resolved
2014-10-11 19:47 gammafunk Fixed in Branch => 0.16 development branch
2014-10-11 19:47 gammafunk Resolution open => done
2014-10-11 19:47 gammafunk Assigned To => gammafunk


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker