Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008842 [DCSS] Bug Report minor always 2014-07-31 11:42 2015-08-17 17:58
Reporter crate View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0008842: Zin hates mana vipers but allows casting summon mana viper
Description If you cast the spell the mana viper you summon will be hostile. Probably Zin should disallow the spell entirely.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026874)
neil (administrator)
2014-07-31 16:43

Two possible fixes: 1) give the spell SPTYP_UNCLEAN (so Zin hates it, as crate suggests); or 2) give mana vipers white chunks instead of purple. I kind of prefer the second option myself, since it's not necessarily clear to players why Zin hates them (the summoned ones don't leave corpses, after all).
(0026875)
neil (administrator)
2014-07-31 21:47

Fixed in 0.15-a0-2373-g7cdf127 by giving them clean rather than mutagenic corpses.

- Issue History
Date Modified Username Field Change
2014-07-31 11:42 crate New Issue
2014-07-31 16:43 neil Note Added: 0026874
2014-07-31 21:47 neil Note Added: 0026875
2014-07-31 21:47 neil Status new => resolved
2014-07-31 21:47 neil Fixed in Branch => 0.15 development branch
2014-07-31 21:47 neil Resolution open => done
2014-07-31 21:47 neil Assigned To => neil
2015-08-17 17:58 crate Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker