Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008836 [DCSS] Bug Report major always 2014-07-29 06:41 2015-10-09 22:29
Reporter Patashu View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008836: Some inconsistencies in corrosion display
Description 1) If you are using unarmed combat and are corroded, your hands are not displayed in dark red, but you still get the corrosion penalty to slaying.
2) If you are using an artifact weapon and are corroded, your artifact weapon is still displayed in white (not dark red) but you still get the corrosion penalty to slaying.
3) On webtiles only:
3a) You do not get the special colours for transmutated UC types (like green for spider and red for blade hands), they are just gray.
3b) The corrosion dark red is never displayed under any circumstances.
(This is because webtiles has its own javascript code to define the interface, and the logic is basically 'look up what colour the item is assigned to and use that, else use gray' and lacks all extra logic that is in console/local tiles version.)

All of these should be fixed one way or the other.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0008267new Ego weapon color displays inconsistently in status area 

-  Notes
(0026872)
neil (administrator)
2014-07-30 13:06

Parts 1 and 2 are fixed in trunk (0.15-a0-2344-ge4dd375), thanks!
(0026984)
edlothiol (developer)
2014-08-12 20:13

3b is done (0.16-a0-129-gbf5829b).
(0029587)
Medar (developer)
2015-10-09 22:29

3a should be fixed by 0.17-a0-2023-g4b4742e.
Also 3b was broken again(?), but fixed in 0.17-a0-2024-gc284f19.

That should wrap this up, if I missed something please reopen (or create a new report).

- Issue History
Date Modified Username Field Change
2014-07-29 06:41 Patashu New Issue
2014-07-30 13:06 neil Note Added: 0026872
2014-08-01 03:13 neil Relationship added related to 0008267
2014-08-12 20:13 edlothiol Note Added: 0026984
2015-10-09 22:29 Medar Note Added: 0029587
2015-10-09 22:29 Medar Status new => resolved
2015-10-09 22:29 Medar Fixed in Branch => 0.17 development branch
2015-10-09 22:29 Medar Resolution open => done
2015-10-09 22:29 Medar Assigned To => Medar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker