Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008804 [DCSS] Bug Report minor have not tried 2014-07-17 09:13 2014-07-18 16:28
Reporter FishServ View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0008804: Granite statues are not stone walls
Description CBRO Webtiles: Targetting a red devil with a longbow(using either tab or f) when it is in a position 'obscured' by a granite statue so as to be both visible and targettable gives message
"Your line of fire to the red devil is blocked by a stone wall. Continue anyway?"

After some derp I have recreated this position with a Hellwing and saved the game. CBRO webtiles FishServ
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026767)
neil (administrator)
2014-07-17 09:45
edited on: 2014-07-17 09:46

This position seems to do it:
..#@
K.8.


You have LOS_DEFAULT to the monster because the statue is transparent: there is a ray that goes through from you to the monster through the statue. The spell tracer and beam, however, consider the statue opaque. Since there is no path at all under LOS_SOLID_SEE, they don't know that the statue path is "better", so use the most direct ray (which goes through the wall) as a fallback.

(0026768)
neil (administrator)
2014-07-17 10:10

Fixed in trunk (0.15-a0-2140-gbaffb6d), thanks!

- Issue History
Date Modified Username Field Change
2014-07-17 09:13 FishServ New Issue
2014-07-17 09:45 neil Note Added: 0026767
2014-07-17 09:46 neil Note Edited: 0026767
2014-07-17 10:10 neil Note Added: 0026768
2014-07-17 10:10 neil Status new => resolved
2014-07-17 10:10 neil Fixed in Branch => 0.15 development branch
2014-07-17 10:10 neil Resolution open => done
2014-07-17 10:10 neil Assigned To => neil
2014-07-18 16:28 FishServ Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker