Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008794 [DCSS] Bug Report minor always 2014-07-14 19:56 2014-07-17 17:03
Reporter neil View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008794: Reflected needles work incorrectly
Description Since the ranged_attack refactor, reflected needles have been rolling using the reflector's skill rather than the original thrower's skill. This is particularly noticeable when the player does the reflection, because that uses the YOU_FAULTLESS monster that has zero HD.

There are probably other, non-blowgun, ranged attacks that have similar problems.

The blowgun checks, and probably several other things in ranged_attack, should use the beam's agent(true) (ignore reflection) rather than agent(). This would involve passing both into at least ranged_attack's constructor; it might also be necessary to pass both into attack's constructor. Both are needed because god blame and XP should go to the reflector (with YOU_FAULTLESS -> you for XP purposes).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026769)
neil (administrator)
2014-07-17 17:03

Should be fixed in 0.15-a0-2141-ge2d3cf6.

- Issue History
Date Modified Username Field Change
2014-07-14 19:56 neil New Issue
2014-07-17 17:03 neil Note Added: 0026769
2014-07-17 17:03 neil Status new => resolved
2014-07-17 17:03 neil Fixed in Branch => 0.15 development branch
2014-07-17 17:03 neil Resolution open => done
2014-07-17 17:03 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker