Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008786 [DCSS] Patches feature N/A 2014-07-13 05:18 2014-07-25 03:18
Reporter infiniplex View Status public  
Assigned To Reaver
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008786: Variants of layout_loops_* for Elf branch
Description Here is a patch that adds special variants of the layout_loops_* for Elf.

The Elf variants have:
  -> More, larger rooms
  -> Room fill styles: 2/3 rooms are open, 1/3 are outlines with filled center, none are outline without touching center (to match the deliberately-constructed feel I have been trying for in Elf)
  -> Some hexagonal rooms
  -> A bit of fiddling in placement to ensure they don't hit map edge
  -> Stair placement on cross happens 50% of the time in Elf and never elsewhere (previously was always 33%). This is only relevant on Elf:2 and I doubt many players will try to bypass that so as to reach Elf:3 faster. The stairs blocks now always use the fancier rooms, but I left the other code in in case we later want to place stairs in some other branch.
  -> Windows as in the geoelf layouts (it even calls the same function). They normally place so they don't do much, but you can sometimes so into an inaccessible room.

The Dungeon (default) variants also have a few minor fixes. They are not in a separate patch because I found these while making the Elf variant.
  -> Removed a few semicolons from line ends
  -> Changed the maximum room size in _cross and _corners to match _ring
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Added-Elf-variant-to-loops-layouts.patch [^] (16,881 bytes) 2014-07-13 05:18 [Show Content]
png file icon layout_loops_all.png [^] (49,485 bytes) 2014-07-13 05:18


png file icon loops_elf_glass_example.png [^] (211,127 bytes) 2014-07-13 05:18

- Relationships

-  Notes
(0026834)
Reaver (developer)
2014-07-25 03:18

Pushed as of e696fdb, Thanks!

- Issue History
Date Modified Username Field Change
2014-07-13 05:18 infiniplex New Issue
2014-07-13 05:18 infiniplex File Added: 0001-Added-Elf-variant-to-loops-layouts.patch
2014-07-13 05:18 infiniplex File Added: layout_loops_all.png
2014-07-13 05:18 infiniplex File Added: loops_elf_glass_example.png
2014-07-25 03:18 Reaver Note Added: 0026834
2014-07-25 03:18 Reaver Status new => resolved
2014-07-25 03:18 Reaver Fixed in Branch => 0.15 development branch
2014-07-25 03:18 Reaver Resolution open => done
2014-07-25 03:18 Reaver Assigned To => Reaver


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker