Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008784 [DCSS] Bug Report minor always 2014-07-13 01:42 2014-07-13 11:51
Reporter Galefury View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0008784: Pcloud targeting bug
Description When I try to cast poisonous cloud, the game tells me there are no susceptible monsters in sight, but there are. Usually it works, just this time it doesn't. There's a berserk Snorg in sight, with some plants in the way.
Additional Information
Tags No tags attached.
Attached Files ? file icon Dronk.cs [^] (954,707 bytes) 2014-07-13 01:42

- Relationships

-  Notes
(0026740)
neil (administrator)
2014-07-13 03:01

Not quite a bug: you can't target Snorg because he is in a cloud already. However, as Galefury pointed out in ##crawl-dev, you are likely to want to aim the second cloud at a nearby spot the monster will soon move into.

Now in trunk (0.15-a0-2042-g3d5dc73) the hostiles-in-range check (but not the actual targetter) ignores existing clouds.

- Issue History
Date Modified Username Field Change
2014-07-13 01:42 Galefury New Issue
2014-07-13 01:42 Galefury File Added: Dronk.cs
2014-07-13 03:01 neil Note Added: 0026740
2014-07-13 03:01 neil Status new => resolved
2014-07-13 03:01 neil Fixed in Branch => 0.15 development branch
2014-07-13 03:01 neil Resolution open => done
2014-07-13 03:01 neil Assigned To => neil
2014-07-13 11:51 Galefury Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker