Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008779 [DCSS] Bug Report text have not tried 2014-07-11 20:13 2015-03-13 01:42
Reporter rchandra View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0008779: removing item from shopping list triggers level entry message for volcano portal
Description Standing on the portal to the volcano, I put on a ring and got the message about the portal as though I had just entered the level:

http://crawl.beRotato.org/crawl/saves/rchandra-crawl-git-65a70f904c-140711-1810.tar.bz2 [^]

You remove your +3 ring of slaying.
 You feel an oppressive heat about you.
 There is an entrance to a volcano on this level. Hurry and find it before the
 entrance collapses!
 Shopping-list: removing a cursed ring of loudness on D:6
 Oops, that ring feels deathly cold.
 E - a cursed ring of loudness (right hand)
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0008408closedneil Examining previous level with X[ reprints portal announcement 
duplicate of 0002814resolvedneil Control F level preview re-prompts "entering level" alerts. 

-  Notes
(0026731)
neil (administrator)
2014-07-11 20:20
edited on: 2014-07-13 23:26

This is the same as 0008408 and 0002814 (temporarily visiting another level and returning to your actual level prints level-entry messages).

In this case the other level is being visited to remove the ring from your shopping list.

(0026732)
wheals (administrator)
2014-07-11 20:50

Updated name to make it more clear.
(0026761)
neil (administrator)
2014-07-15 08:18

This should be fixed in trunk (0.15-a0-2111-ga61266d). Please re-open 0002814 if the problem reappears.

- Issue History
Date Modified Username Field Change
2014-07-11 20:13 rchandra New Issue
2014-07-11 20:18 neil Relationship added duplicate of 0008408
2014-07-11 20:19 neil Relationship added duplicate of 0002814
2014-07-11 20:20 neil Note Added: 0026731
2014-07-11 20:50 wheals Note Added: 0026732
2014-07-11 20:50 wheals Summary changing rings triggers level entry message for volcano portal => removing item from shopping list triggers level entry message for volcano portal
2014-07-13 23:26 neil Note Edited: 0026731
2014-07-15 08:18 neil Note Added: 0026761
2014-07-15 08:18 neil Status new => resolved
2014-07-15 08:18 neil Fixed in Branch => 0.15 development branch
2014-07-15 08:18 neil Resolution open => done
2014-07-15 08:18 neil Assigned To => neil
2015-03-13 01:42 rchandra Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker