Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008765 [DCSS] Bug Report minor always 2014-07-07 01:47 2015-08-17 17:58
Reporter crate View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0008765: Curare slowing and slow+haste on x
Description Every time you curare a monster you get a "foo seems to slow down" message, even if said foo is already slow. This is confusing because it's not slowing down in that case (it's staying slow longer, or something).

Additionally if you curare a berserk monster, the monster is then listed (when you x over it) as being "berserk, moving slowly". Technically this is true, but it's also misleading since the monster is normal speed. I'm not sure what to suggest for a fix here, possibly just always explicitly show the haste + might effects of berserk in x (which makes the effects of berserk more apparent anyway).

Monster haste + slow correctly shows the monster as normal speed in x, but probably it should list "fast + slow" like on the player status bar (otherwise it's not clear you cannot further slow or haste said monster).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026695)
wheals (administrator)
2014-07-07 15:27

Both issues should be fixed in trunk.

- Issue History
Date Modified Username Field Change
2014-07-07 01:47 crate New Issue
2014-07-07 15:27 wheals Note Added: 0026695
2014-07-07 15:27 wheals Status new => resolved
2014-07-07 15:27 wheals Fixed in Branch => 0.15 development branch
2014-07-07 15:27 wheals Resolution open => done
2014-07-07 15:27 wheals Assigned To => wheals
2015-08-17 17:58 crate Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker