Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008763 [DCSS] Bug Report minor always 2014-07-04 23:37 2015-08-17 17:57
Reporter crate View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0008763: Some summons can use stairs and some cannot and the distinction feels arbitrary
Description Summons that cannot use stairs are most (but not all!) summons from spells. Presumably this is the desired state of affairs, since summons were specifically changed to act this way a while ago.

Summons that can use stairs include (but are not limited to): sticks to snakes, scroll of summoning, TSO god ability summons, probably a lot more.

This behaviour is confusing and should probably be made consistent. I would personally suggest making all summons unable to use stairs.

Since this would be a significant nerf to TSO angel summons (it should not really affect other summons much) I would suggest a corresponding piety cost decrease, or if it's deemed unacceptable to limit A summons to one floor they could be the single exception to this rule. But things like scroll of summoning and sticks to snakes should work like the majority of summon spells.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0007287resolvedwheals Monsters summoned with rod of swarms can follow player down stairs 

-  Notes
(0026729)
crate (reporter)
2014-07-11 15:11

Also, one particularly problematic case of can-use-stairs summons is lantern of shadows, since these are completely repeatable to summon.
(0028316)
MarvinPA (developer)
2015-01-20 14:22

Made all non-permanent summons unable to take stairs.

- Issue History
Date Modified Username Field Change
2014-07-04 23:37 crate New Issue
2014-07-11 15:11 crate Note Added: 0026729
2014-11-23 01:07 wheals Relationship added has duplicate 0007287
2015-01-20 14:22 MarvinPA Note Added: 0028316
2015-01-20 14:22 MarvinPA Status new => resolved
2015-01-20 14:22 MarvinPA Fixed in Branch => 0.16 development branch
2015-01-20 14:22 MarvinPA Resolution open => done
2015-01-20 14:22 MarvinPA Assigned To => MarvinPA
2015-08-17 17:57 crate Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker