Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008742 [DCSS] Bug Report tweak N/A 2014-06-27 06:18 2014-11-01 04:09
Reporter Skrybe View Status public  
Assigned To doy
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0008742: Depths displayed after Zot on dungeon overview
Description On the Ctrl-O dungeon overview screen, Depths is placed on the end of the list, after Zot. Everything else is displayed in more or less the order it would be encountered (Dungeon first, then Temple, Orc, etc.) Having Depths on the end of the list looks very out of place. Listing it between Tomb and Hell seems more appropriate.

The same issue is present in the Ctrl-G dialog. I haven't noticed it anywhere else.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026646)
infiniplex (reporter)
2014-06-27 21:55

Also shows up in the Wizmode "~" command, where it is after portal vaults as well.

I have no actual knowledge, but I would assume that this is because all the branches are in an enum, and they can't add one to the middle without breaking all saved games. If so, this cannot be fixed until the next (internal) major version, at which point it will be trivial.
(0026902)
doy (developer)
2014-08-03 02:11

Fixed in 4e1b44a, thanks!

- Issue History
Date Modified Username Field Change
2014-06-27 06:18 Skrybe New Issue
2014-06-27 21:55 infiniplex Note Added: 0026646
2014-08-03 02:11 doy Note Added: 0026902
2014-08-03 02:11 doy Status new => resolved
2014-08-03 02:11 doy Fixed in Branch => 0.15 development branch
2014-08-03 02:11 doy Resolution open => done
2014-08-03 02:11 doy Assigned To => doy
2014-11-01 04:09 Skrybe Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker