Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008717 [DCSS] Bug Report crash always 2014-06-20 23:25 2014-06-23 01:58
Reporter muxecoid View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008717: Offlevel recalling a monster onto a shaft crashes
Description It crashed while I explored elf 1. I tried to restart from autosave several times and it crashed again once I started exploring the same area.

Dump: http://crawl.akrasiac.org/rawdata/muxecoid/crash-muxecoid-20140620-211747.txt [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026572)
neil (administrator)
2014-06-21 00:12

Retitled. This is happening because placing the monster can now trigger shafts (0.15-a0-1326-g1a204a1), but we proceed as though the monster were still around.

Fixing it is kind of tricky, though: we haven't placed the monster's items, so they'd be in the wrong place whether we leave them alone or go ahead and place them on the spot: they should go in transit to the same level the monster just fell to, but I think it's too late to find out where that is.
(0026573)
neil (administrator)
2014-06-21 00:13

Save at: http://crawl.akrasiac.org/saves/muxecoid.cs [^]
(0026585)
PleasingFungus (administrator)
2014-06-23 01:58

Should be fixed in c76c7bb6, thanks!

- Issue History
Date Modified Username Field Change
2014-06-20 23:25 muxecoid New Issue
2014-06-21 00:12 neil Note Added: 0026572
2014-06-21 00:12 neil Summary Crash in webtiles - reproducible => Offlevel recalling a monster onto a shaft crashes
2014-06-21 00:13 neil Note Added: 0026573
2014-06-23 01:58 PleasingFungus Note Added: 0026585
2014-06-23 01:58 PleasingFungus Status new => resolved
2014-06-23 01:58 PleasingFungus Fixed in Branch => 0.15 development branch
2014-06-23 01:58 PleasingFungus Resolution open => done
2014-06-23 01:58 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker