Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008706 [DCSS] Bug Report minor always 2014-06-19 01:48 2014-06-19 04:03
Reporter Lasty View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008706: Summon Swarm spell code has potentially infinite loop
Description The code for summon swarm calls a while loop that doesn't necessarily end, particularly if your god hates a lot of stuff. It should probably be capped at 20 tries like shadow creatures.

The patch below fixes it. Please apply to trunk and then rebase Iashol onto trunk, since it fixes a guaranteed infinite loop there.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Stop-Summon-Swarm-from-looping-infinitely 2.patch [^] (1,411 bytes) 2014-06-19 02:22 [Show Content]

- Relationships

-  Notes
(0026554)
Lasty (developer)
2014-06-19 02:22

Uploaded w/ a break statement, per |amethyst
(0026556)
neil (administrator)
2014-06-19 04:03

In trunk (0.15-a0-1582-geaab847) and Iashol branch (0.15-a0-1546-g4aea661), with some tweaks. Thanks!

- Issue History
Date Modified Username Field Change
2014-06-19 01:48 Lasty New Issue
2014-06-19 01:48 Lasty File Added: 0001-Stop-Summon-Swarm-from-looping-infinitely.patch
2014-06-19 02:22 Lasty File Added: 0001-Stop-Summon-Swarm-from-looping-infinitely 2.patch
2014-06-19 02:22 Lasty Note Added: 0026554
2014-06-19 02:23 neil File Deleted: 0001-Stop-Summon-Swarm-from-looping-infinitely.patch
2014-06-19 04:03 neil Note Added: 0026556
2014-06-19 04:03 neil Status new => resolved
2014-06-19 04:03 neil Fixed in Branch => 0.15 development branch
2014-06-19 04:03 neil Resolution open => done
2014-06-19 04:03 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker