Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008701 [DCSS] Bug Report tweak have not tried 2014-06-18 06:39 2015-03-29 09:08
Reporter rchandra View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.15 ancient branch
Summary 0008701: changing gods puts the new gods abilities on new letters
Description Usually, for example, Qazlal's Upheaval is on a. But I started as a Healer and switched to him, now it is on f.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026545)
PleasingFungus (administrator)
2014-06-18 07:03

Replicated; seems to be specifically an ely->qaz thing. Occurs no matter what your ely piety was.
(0026800)
neil (administrator)
2014-07-21 03:12

It is intentional that new abilities don't reuse letters of old abilities, because it may be just a temporary disability blocking the ability.

However, I think it would be reasonable to forget the letter assignments for a god's abilities when abandoning that god. It would make things a little more annoying for people who want to switch back to the first god and keep the old mappings, but your case is much the more common.
(0026801)
neil (administrator)
2014-07-21 03:27

Ah.... they are forgotten, but that is missing the zero-star abilities like Lesser Healing Others.
(0026802)
neil (administrator)
2014-07-21 03:37

Fixed in trunk (0.15-a0-2181-gfe1f898), thanks!

- Issue History
Date Modified Username Field Change
2014-06-18 06:39 rchandra New Issue
2014-06-18 07:03 PleasingFungus Note Added: 0026545
2014-07-21 03:12 neil Note Added: 0026800
2014-07-21 03:27 neil Note Added: 0026801
2014-07-21 03:37 neil Note Added: 0026802
2014-07-21 03:37 neil Status new => resolved
2014-07-21 03:37 neil Fixed in Branch => 0.15 development branch
2014-07-21 03:37 neil Resolution open => done
2014-07-21 03:37 neil Assigned To => neil
2015-03-29 09:08 rchandra Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker