Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008684 [DCSS] Patches feature have not tried 2014-06-14 08:56 2014-06-15 14:11
Reporter SiotWarrior View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008684: Problem of new equip system of beogh orc follower
Description i got answer that original purpose of new equip system is not nerf

if so, true purpose of new equip system is arranging prior complex interface

but now, new equip system is critical nerf to skilled beogh users in korea

because skilled beogh users freely change equipment of orc by using macro(\{20}p.\{20}n. - \{20} is system return key of Crtl + T), picking bare-handed orc and predicting result of weapon valuation function for monster.

i think that this problem is about gab between users and developer for understanding of beogh play.

In summary,
1. original purpose of new equip system is not nerf
2. skilled beogh users freely change equipment of orc
3. but now, at piety[*****] we can change just once only weapon
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026490)
Roarke (reporter)
2014-06-14 12:20

Have any devs ever seen the Beogh speedruns? They are really quite something, and are totally eliminated by the mon-pickup removal. The basic strategy, as I understood it, was to gather about 4 orcs, give them one-handed polearms (holy wrath, antimagic, and similar brands), shields, and decent armor. They would then train up those orcs and micromanage them to beat the game in very few turns.
Mon-pickup and Ctrl-T were necessary for these tactics.
http://kr.dobrazupa.org/morgue/trunk/hanon12/morgue-hanon12-20140605-162326.txt [^]
This is a log of one such recent game. It is probably possible to watch the ttyrec on FooTV.
(0026492)
DrKe (reporter)
2014-06-14 12:35

!lg hanon12 hofi won -tv:<T1:>>:x4
(0026493)
MarvinPA (developer)
2014-06-14 12:43

The purpose of the change was to improve the interface generally and not to nerf Beogh specifically, yes, but the fact that it ends up nerfing Beogh in some ways as a result also isn't especially a problem and definitely isn't a bug. Making some speedrun techniques harder or impossible is even less of a problem than something that would significantly affect normal games. If Beogh turns out to be too weak in normal games then it'll be pretty easy to adjust his item upgrades in some way (one thing that has been mentioned is allowing Beogh to grant ranged weapons and ammo, along with the existing upgrades).
(0026509)
SiotWarrior (reporter)
2014-06-15 14:03
edited on: 2014-06-15 14:12

A long time ago, stone soup user's objective is just escaping with 3 runes or 15 runes though it may take much time

But,

as overall stone soup user's skill had improved for a long time, their objective changed to speedrun.

Why do you want to distinguish normal game and speed run.

(0026510)
SiotWarrior (reporter)
2014-06-15 14:11
edited on: 2014-06-15 14:11

In addition, a character suitable for speedrun means that he is powerful throughout the entire game.

Naturally, the character is powerful in normal game.

Making speedrun impossible also means that weakening in normal game.


- Issue History
Date Modified Username Field Change
2014-06-14 08:56 SiotWarrior New Issue
2014-06-14 12:20 Roarke Note Added: 0026490
2014-06-14 12:35 DrKe Note Added: 0026492
2014-06-14 12:43 MarvinPA Note Added: 0026493
2014-06-14 12:43 MarvinPA Status new => resolved
2014-06-14 12:43 MarvinPA Fixed in Branch => 0.15 development branch
2014-06-14 12:43 MarvinPA Resolution open => done
2014-06-14 12:43 MarvinPA Assigned To => MarvinPA
2014-06-15 14:03 SiotWarrior Note Added: 0026509
2014-06-15 14:11 SiotWarrior Note Added: 0026510
2014-06-15 14:11 SiotWarrior Note Edited: 0026510
2014-06-15 14:12 SiotWarrior Note Edited: 0026509


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker