Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008681 [DCSS] Bug Report minor always 2014-06-14 00:03 2014-06-14 12:23
Reporter nogardnew View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008681: Summon Guardian Golem description unclear
Description Guardian Golem receives damage done to allies, but the player takes damage normally.
Tested in normal mode and Wizard mode.
Windows 7 32.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026479)
sgrunt (administrator)
2014-06-14 00:06

This is (apparently) the intended behaviour of the spell, i.e. shielding only your allies.
(0026481)
nogardnew (reporter)
2014-06-14 00:43

I only reported this because of the changelog:
228- Summon Guardian Golem (L4 Summoning/Charms), which creates a golem
229- that protects the player with Injury Bond and occasionally explodes
230- on death; appears in the book of Callings.

And the spell description:
This spell summons a protective golem. It redirects the injuries of its allies to itself, though it risks overheating after absorbing significant amounts of damage. It will gain more health at high power. You can sustain at most one creature summoned by this spell.

In both cases, isn't very clear the "shielding only your allies" mechanic. I mean, the player is an ally of the golem.


Thanks for the attention.
(0026491)
MarvinPA (developer)
2014-06-14 12:23

Fixed by 3e22f2781784.

- Issue History
Date Modified Username Field Change
2014-06-14 00:03 nogardnew New Issue
2014-06-14 00:06 sgrunt Note Added: 0026479
2014-06-14 00:06 sgrunt Status new => resolved
2014-06-14 00:06 sgrunt Resolution open => no change required
2014-06-14 00:43 nogardnew Note Added: 0026481
2014-06-14 01:03 sgrunt Status resolved => new
2014-06-14 01:03 sgrunt Resolution no change required => reopened
2014-06-14 01:03 sgrunt Summary Summon Guardian Golem: Injury Bond doesn't work properly => Summon Guardian Golem description unclear
2014-06-14 12:23 MarvinPA Note Added: 0026491
2014-06-14 12:23 MarvinPA Status new => resolved
2014-06-14 12:23 MarvinPA Fixed in Branch => 0.15 development branch
2014-06-14 12:23 MarvinPA Resolution reopened => done
2014-06-14 12:23 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker