Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008663 [DCSS] Patches feature N/A 2014-06-09 00:57 2014-09-16 01:53
Reporter Lasty View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008663: New god: Iashol
Description I've attached the patch for the new god of sacrifice I coded up (see tavern and dev wiki for design plan).

I believe it still has a bug involving allowing players to wear a second ring and two-handed weapon while missing a hand, but that may only be in wizard mode.

I'd love to get this on an experimental branch if it's acceptable.
Additional Information
Tags No tags attached.
Attached Files ? file icon iashol.patch [^] (93,969 bytes) 2014-06-09 00:57 [Show Content]
? file icon iashol3.patch [^] (144,319 bytes) 2014-06-09 03:27
? file icon iashol4.patch [^] (159,303 bytes) 2014-06-09 03:41
? file icon iashol5.patch [^] (123,357 bytes) 2014-06-12 03:24
? file icon iashol6.patch [^] (129,706 bytes) 2014-06-13 02:33
? file icon iashol7.patch [^] (136,073 bytes) 2014-06-14 13:46
? file icon iashol8.patch [^] (136,255 bytes) 2014-06-14 15:27
? file icon iashol9.patch [^] (130,700 bytes) 2014-06-14 18:54
? file icon iashol10.patch [^] (157,210 bytes) 2014-06-14 19:39
? file icon iashol11.patch [^] (127,725 bytes) 2014-06-14 22:27
? file icon iashol12.patch [^] (126,229 bytes) 2014-06-14 22:47
? file icon iashol_cleanups.diff [^] (8,854 bytes) 2014-06-14 23:41 [Show Content]
? file icon 0001-IASHOL-EXPERIMENTAL-ONLY-Add-minor-tag-for-save-chan.patch [^] (1,865 bytes) 2014-06-15 23:59 [Show Content]
? file icon save-load_Iashol_variables.patch [^] (26,111 bytes) 2014-06-16 00:17 [Show Content]
? file icon 0001-Iashol-Fix-Missing-Hand.patch [^] (4,353 bytes) 2014-06-16 01:45 [Show Content]
? file icon 0001-Iashol-Fix-Essence-mutation-description.patch [^] (1,082 bytes) 2014-06-16 01:59 [Show Content]
? file icon 0001-Iashol-Block-skill-training-from-sacrificed-skill.patch [^] (4,919 bytes) 2014-06-16 02:53 [Show Content]
? file icon 0001-Iashol-Amnesia-forbidden-schools.patch [^] (6,549 bytes) 2014-06-16 03:56 [Show Content]
? file icon 0001-Iashol-Offer-monks-the-first-sacrifice-right-away.patch [^] (1,022 bytes) 2014-06-16 04:21 [Show Content]

- Relationships
has duplicate 0008693closedneil Iashol: adding saving/loading of Iashol variables 

-  Notes
(0026436)
sgrunt (administrator)
2014-06-09 02:17

I can immediately point out a crippling (heh) issue with this - inserting enums in the middle of lists will break save compatibility horribly. Please move your enums to the end of their respective sets.

As we mentioned on IRC, it's probably a good idea to break this down into more manageable individual commits (which I hope you still have somewhere).

Also, you have an extraneous "the" in the altar description.
(0026437)
Lasty (developer)
2014-06-09 03:42

Patch 4 fixes the typo and enums issues as well as breaking the changes out into multiple commits.
(0026470)
Lasty (developer)
2014-06-12 03:24

Patch 5 is rebased according to all the specs we discussed, and also compiles on every commit.
(0026475)
Lasty (developer)
2014-06-13 02:34

Patch 6 compiles under FULLDEBUG=Y, and fixing a couple other issues, including a crash on the ^ screen.
(0026494)
Lasty (developer)
2014-06-14 13:46

Patch 7 resolves the remaining issues with the one-handed conduct alluded to in the initial description as well as improving the mechanics that determine how often Iashol offers a new sacrifice.
(0026495)
MarvinPA (developer)
2014-06-14 14:55
edited on: 2014-06-14 14:56

There still seem to be a lot of commits with content that looks like it's intended for a different commit.

The "sacrifice sanity" commit contains a lot of handling for sacrificing scrolls and magic schools. It also adds a big list of statuses to important_statuses[] in output.cc, this is just meant to be a short list of status lights to be displayed first now, and the rest are dealt with automatically (it looks like a mis-merge adding the old list back). The "sacrifice hand" commit looks like it adds in a mutation in the wrong place, and then the next commit removes it again, also.

I'm just trying to get it to apply/compile/run cleanly rather than review code or anything at the moment but I noticed that you have "arcane_mutation_to_skill()" as well as "arcane_mutation_to_school_name()", I'm not sure you need two hard-coded lists there when you could just do something like "skill_name(arcane_mutation_to_skill(MUT_WHATEVER))". Possibly there's a neater way to handle the hard-coded lists for useless skills and useless spells, too (iterate over mutations and see if any of them render the skill/spell useless?).

If you have a Gitorious/Github branch with the god, that would probably be a lot easier to work with than these patches, unless somebody else has gotten it to apply neatly?

(0026496)
Lasty (developer)
2014-06-14 15:29

patch 8 has fixes for some issues that came up in playtesting (rate of sacrifice offers, how often a horror message is displayed). It doesn't resolve the issues MarvinPA identified.
(0026497)
Lasty (developer)
2014-06-14 18:54

Patch 9 rebases everything again, which should resolve the issues MarvinPA described.
(0026498)
Lasty (developer)
2014-06-14 19:39

Patch 10 rebases onto master in an attempt to fix the 3-way merge issue.
(0026499)
Lasty (developer)
2014-06-14 22:28

Patch 11 improves god text, puts back in some goofy commas in unrelated code, ups the drain cost for cataclysm, and some other miscellaneous fixes. This is meant to be the last version before we create a branch and start uploaded new fixes as their own commits.
(0026500)
Lasty (developer)
2014-06-14 22:47

Patch 12 fixes some issues in Patch 11
(0026501)
gammafunk (administrator)
2014-06-14 23:40

I created an iashol branch based on a cleaned version of iashol12.patch in 0.15-a0-1506-g7ab5695, thanks. See the attached diff for the code changes from checkwhite and unbrace (the former only found a newline at the end of godabil.cc, but the latter cleaned up a lot of braces). The attached iashol_cleanups.diff file shows you examples of our coding standard for braces: always a brace if the condition is multiple lines, never a brace if it's a one-line condition and a one-line statement in the block, etc.

After some people have looked over the code and the god and maybe play tested it a bit locally, we can make an experimental branch.
(0026502)
gammafunk (administrator)
2014-06-14 23:49

I should also note that I cleanup some of you commit comments to reformat them consistently to 72-chars per line (a few weren't wrapped) and fixed some of the language.

Any further changes will go into this branch as subsequent commits, including merges from trunk. So don't rebase any commits that are already in this branch (either this set or subsequent ones that get applied). It's also ok (and generally a good idea) to merge trunk whenever you submit some commits (having a repo on gitorious or github can be helpful there).
(0026530)
Lasty (developer)
2014-06-15 23:59

Added a patch to minor-tagify the recent save changes for compatibility.
(0026531)
Lasty (developer)
2014-06-16 00:18

Added new patch that includes both the save/load changes and the compatibility changes. Also fixes some remaining debug stuff.
(0026532)
Lasty (developer)
2014-06-16 01:45

Uploaded a patch to fix the missing hand issues.
(0026533)
Lasty (developer)
2014-06-16 01:59

Uploaded a patch to fix mutation typos.
(0026534)
Lasty (developer)
2014-06-16 02:53

Uploaded a patch to fix skill sacrifices.
(0026535)
Lasty (developer)
2014-06-16 03:56

Uploaded a patch to fix arcane sacrifice limitations.
(0026536)
Lasty (developer)
2014-06-16 04:22

Uploaded a patch to give monks an immediate sacrifice instead of bonus piety.
(0027277)
wheals (administrator)
2014-09-16 01:53

In trunk \o/

- Issue History
Date Modified Username Field Change
2014-06-09 00:57 Lasty New Issue
2014-06-09 00:57 Lasty File Added: iashol.patch
2014-06-09 02:17 sgrunt Note Added: 0026436
2014-06-09 03:27 Lasty File Added: iashol3.patch
2014-06-09 03:41 Lasty File Added: iashol4.patch
2014-06-09 03:42 Lasty Note Added: 0026437
2014-06-12 03:24 Lasty File Added: iashol5.patch
2014-06-12 03:24 Lasty Note Added: 0026470
2014-06-13 02:33 Lasty File Added: iashol6.patch
2014-06-13 02:34 Lasty Note Added: 0026475
2014-06-14 13:46 Lasty File Added: iashol7.patch
2014-06-14 13:46 Lasty Note Added: 0026494
2014-06-14 14:55 MarvinPA Note Added: 0026495
2014-06-14 14:56 MarvinPA Note Edited: 0026495
2014-06-14 15:27 Lasty File Added: iashol8.patch
2014-06-14 15:29 Lasty Note Added: 0026496
2014-06-14 18:54 Lasty File Added: iashol9.patch
2014-06-14 18:54 Lasty Note Added: 0026497
2014-06-14 19:39 Lasty File Added: iashol10.patch
2014-06-14 19:39 Lasty Note Added: 0026498
2014-06-14 22:27 Lasty File Added: iashol11.patch
2014-06-14 22:28 Lasty Note Added: 0026499
2014-06-14 22:47 Lasty File Added: iashol12.patch
2014-06-14 22:47 Lasty Note Added: 0026500
2014-06-14 23:40 gammafunk Note Added: 0026501
2014-06-14 23:40 gammafunk Status new => confirmed
2014-06-14 23:41 gammafunk File Added: iashol_cleanups.diff
2014-06-14 23:49 gammafunk Note Added: 0026502
2014-06-15 23:59 Lasty File Added: 0001-IASHOL-EXPERIMENTAL-ONLY-Add-minor-tag-for-save-chan.patch
2014-06-15 23:59 Lasty Note Added: 0026530
2014-06-16 00:09 neil Relationship added has duplicate 0008693
2014-06-16 00:17 Lasty File Added: save-load_Iashol_variables.patch
2014-06-16 00:18 Lasty Note Added: 0026531
2014-06-16 01:45 Lasty File Added: 0001-Iashol-Fix-Missing-Hand.patch
2014-06-16 01:45 Lasty Note Added: 0026532
2014-06-16 01:59 Lasty File Added: 0001-Iashol-Fix-Essence-mutation-description.patch
2014-06-16 01:59 Lasty Note Added: 0026533
2014-06-16 02:53 Lasty File Added: 0001-Iashol-Block-skill-training-from-sacrificed-skill.patch
2014-06-16 02:53 Lasty Note Added: 0026534
2014-06-16 03:56 Lasty File Added: 0001-Iashol-Amnesia-forbidden-schools.patch
2014-06-16 03:56 Lasty Note Added: 0026535
2014-06-16 04:21 Lasty File Added: 0001-Iashol-Offer-monks-the-first-sacrifice-right-away.patch
2014-06-16 04:22 Lasty Note Added: 0026536
2014-09-16 01:53 wheals Note Added: 0027277
2014-09-16 01:53 wheals Status confirmed => resolved
2014-09-16 01:53 wheals Fixed in Branch => 0.16 development branch
2014-09-16 01:53 wheals Resolution open => done
2014-09-16 01:53 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker