Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008659 [DCSS] Patches minor N/A 2014-06-08 01:48 2014-06-08 03:17
Reporter johlstei View Status public  
Assigned To Reaver
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008659: Automatically eat food while resting/autoexploring
Description Given that there is no more chunk eating in the chunkless branch, I have repurposed the auto_eat_chunks and the easy_eat_chunks options to eat rations/jerky/other non-fruit food instead. It won't eat anything until your hunger is low enough that no nutrition would be wasted.

These may need to be renamed to their own options, instead of just overloading their meaning. (The chunk behavior still exists for ghouls.)

easy_eat_chunks will automatically eat food such that you won't waste nutrition whenever you hit e and no monsters are visible. auto_eat_chunks will automatically eat food when you are travelling. Fruit is not automatically eaten because it has tactical value that other food doesn't, and would end up being eaten first.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-make-auto_eat_chunks-also-automatically-eat-rations.patch [^] (4,460 bytes) 2014-06-08 01:48 [Show Content]

- Relationships

-  Notes
(0026428)
Reaver (developer)
2014-06-08 03:17

Pushed to chunkless, thanks!

- Issue History
Date Modified Username Field Change
2014-06-08 01:48 johlstei New Issue
2014-06-08 01:48 johlstei File Added: 0001-make-auto_eat_chunks-also-automatically-eat-rations.patch
2014-06-08 03:17 Reaver Note Added: 0026428
2014-06-08 03:17 Reaver Status new => resolved
2014-06-08 03:17 Reaver Fixed in Branch => 0.15 development branch
2014-06-08 03:17 Reaver Resolution open => done
2014-06-08 03:17 Reaver Assigned To => Reaver


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker