Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008643 [DCSS] Bug Report crash sometimes 2014-06-04 17:18 2014-06-04 22:13
Reporter SchwaWarrior View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008643: Game crashes, something to do with Stone Golems (possibly Igni's Wrath)
Description My DsFi of the new god Igni just abandoned Igni and picked Lugonu. Ever since then my game is CONSTANTLY crashing, at random intervals; it has happened three times and this is the message I get:

line 1218: invalid monster to place: removed MONS_STONE_GOLEM (147)

I have a suspicion that maybe this is Igni's Wrath trying to kick in, and it's not working right? But I have no way to prove this.

Here is the last crash log I've gotten: http://dobrazupa.org/morgue/SchwaWarrior/crash-SchwaWarrior-20140604-150525.txt [^]

I'm playing under the account "SchwaWarrior", on the CSZO server. Webtiles, not glyphs.

I hope you can figure this one out soon, my game is currently un-playable as-is.

On a side note, part of why I abandoned Igni in favor of Lugonu was that "this new god is brand new to Crawl and maybe I can provide more feedback if I see what his Wrath is like". It'd be awesomely ironic if I actually helped catch a fatal bug because of this, hehe :)
Additional Information
Tags No tags attached.
Attached Files txt file icon schwawarrior.txt [^] (52,066 bytes) 2014-06-04 17:18 [Show Content]

- Relationships

-  Notes
(0026385)
neil (administrator)
2014-06-04 22:13

That was exactly the problem, good catch! Fixed in 0.15-a0-1176-g886b033, replacing the stone golems with earth elementals.

- Issue History
Date Modified Username Field Change
2014-06-04 17:18 SchwaWarrior New Issue
2014-06-04 17:18 SchwaWarrior File Added: schwawarrior.txt
2014-06-04 22:13 neil Note Added: 0026385
2014-06-04 22:13 neil Status new => resolved
2014-06-04 22:13 neil Fixed in Branch => 0.15 development branch
2014-06-04 22:13 neil Resolution open => done
2014-06-04 22:13 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker