Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008629 [DCSS] Bug Report minor have not tried 2014-06-02 18:59 2015-03-30 21:23
Reporter NTRAFF View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008629: Natasha will not display her death message if killed while unable to act
Description Retitled to reflect the remaining part of the problem.

Original report "Natasha will not display her death message if she kills herself while confused." follows:

Natasha casted Mephetic Cloud when she was at low health and ended up confusing herself. She then proceeded to attack herself in confusion, which resulted in her killing herself.

This did not trigger her usual death message, but it did not otherwise affect her revival/death behavior (subsequent deaths resulted in the expected messages).

I do not know if her dying during confusion due to other causes will have similar effects.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026373)
golthoon (reporter)
2014-06-03 02:37

May be related to 0008539
(0026391)
NTRAFF (reporter)
2014-06-05 06:02

I can confirm that killing Natasha yourself while she's confused also doesn't trigger her death message.
(0026412)
neil (administrator)
2014-06-06 22:05
edited on: 2014-06-06 22:13

Fixed in trunk (0.15-a0-1309-g3520d71), thanks!

What is more difficult is handling the case where she was asleep or otherwise could not act: that normally prevents any "speech", but shouldn't prevent the "finally been put to rest" messages, or for that matter the messages that refer to her spirit. Therefore I am leaving this bug open.

See the first if statement in mons_speaks: this is the thing that would have to be adjusted somehow:
http://s-z.org/neil/git/?p=crawl.git;a=blob;f=crawl-ref/source/mon-speak.cc;h=b85b3b4;hb=3520d71#l404 [^]

(0028742)
wheals (administrator)
2015-03-30 21:22

Fixed by http://s-z.org/neil/git/?p=crawl.git;a=commitdiff;h=22d161bb0095. [^]

- Issue History
Date Modified Username Field Change
2014-06-02 18:59 NTRAFF New Issue
2014-06-03 02:37 golthoon Note Added: 0026373
2014-06-05 06:02 NTRAFF Note Added: 0026391
2014-06-06 22:05 neil Note Added: 0026412
2014-06-06 22:07 neil Note Edited: 0026412
2014-06-06 22:09 neil Summary Natasha will not display her death message is she kills herself while confused. => Natasha will not display her death message if killed while unable to act
2014-06-06 22:09 neil Description Updated
2014-06-06 22:13 neil Note Edited: 0026412
2015-03-30 21:22 wheals Note Added: 0028742
2015-03-30 21:22 wheals Status new => resolved
2015-03-30 21:22 wheals Fixed in Branch => 0.17 development branch
2015-03-30 21:22 wheals Resolution open => done
2015-03-30 21:22 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker