Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008606 [DCSS] Bug Report major always 2014-05-28 01:41 2015-02-19 21:57
Reporter feralfantom View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008606: Unresponsive loading incompatible save after update, key presses showing up in other programs
Description Downloaded version 9 from synaptic, worked fine and played it some, saved and exited a game. Then I decided to update to 14 so I went through all of that process for linux tiles. When I loaded it up, first of it says done loading press any key, I have to mouse click after pressing a key to get it to actually update the display. Then I click new game and it says incompatible save you have to reinstall do you want to delete the save and start a new game. Whatever key I hit, I then have to click and it will say [Y]es or [N]o only please and repeat the message, then it will just sit there doing nothing no matter what keys I press or if I click with the mouse, it doesn't repeat the message any more and I have to ctrl-alt-f1 into terminal to kill it. I then noticed that after going back to the desktop, all the keys I was hitting, including the first key where it responds saying [Y]es or [N]o only and whatever keys I pressed at the press any key screen appear in the text box of whatever program is now active, be it skype or a search engine or whatever. I tried doing a reinstall but it still has the old save. I don't know where to find the save to attempt deleting it or where to find a log.

I am on Bodhi Linux 2.4 which is off of Ubuntu and uses enlightenment desktop environment. On a lenovo ideapad y460 intel processor, amd mobility radeon 5650 HD with and integrated intel chip.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026306)
feralfantom (reporter)
2014-05-29 05:55

doesn't happen if all other programs are minimized. probably an issue with how the game interacts with the enlightenment desktop environment
(0028535)
gammafunk (administrator)
2015-02-19 21:57

I can confirm that the incompatible save dialogue works fine in trunk Tiles on ubuntu using the mouse. Clicking through I can get to the [Y] [N] choice by hitting and invalid key, and it does respond correctly when I do hit Y or N. I didn't have all applications minimized and still no issue. This is with the Unity desktop environment. We've switched to SDL2 since 0.14, so this might not be an issue even when using Enlightenment in current trunk (soon to be 0.16). We don't really support specific desktop environments under Linux, but if you still see this issue in trunk, you can reopen, and perhaps one of us can install Enlightenment and test.

- Issue History
Date Modified Username Field Change
2014-05-28 01:41 feralfantom New Issue
2014-05-29 05:55 feralfantom Note Added: 0026306
2015-02-19 21:57 gammafunk Note Added: 0028535
2015-02-19 21:57 gammafunk Status new => resolved
2015-02-19 21:57 gammafunk Fixed in Branch => 0.16 development branch
2015-02-19 21:57 gammafunk Resolution open => done
2015-02-19 21:57 gammafunk Assigned To => gammafunk


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker