Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008594 [DCSS] Bug Report minor always 2014-05-26 10:03 2014-06-04 12:30
Reporter bemyak View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008594: Build failed on OpenSuse <=12.3
Description Hi! I'm trying to build package for OpenSuse, but it fails with an error:

I: A function overflows or underflows an array access. This could be a real error,
but occasionaly this condition is also misdetected due to loop unrolling or strange pointer handling. So this is warning only, please review.
W: crawl arraysubscript mon-util.cc:4962
I: Program uses operation a <= b <= c, which is not well defined.
E: crawl mathmeaning dgn-proclayouts.cc:550
E: crawl mathmeaning mon-info.cc:1202

Full build log is attached.
Additional Information
Tags No tags attached.
Attached Files ? file icon _log [^] (276,740 bytes) 2014-05-26 10:03

- Relationships

-  Notes
(0026349)
neil (administrator)
2014-05-31 20:08

Fixed in trunk (0.15-a0-1200-g0555b25 + 0.15-a0-1201-g48301db) and stable (0.14.1-12-g89392ac + 0.14.1-13-g247c73f), thanks!
(0026381)
bemyak (reporter)
2014-06-04 12:30

Where can I download it? It seems like these archives haven’t yet been published

- Issue History
Date Modified Username Field Change
2014-05-26 10:03 bemyak New Issue
2014-05-26 10:03 bemyak File Added: _log
2014-05-31 20:08 neil Note Added: 0026349
2014-05-31 20:08 neil Status new => resolved
2014-05-31 20:08 neil Fixed in Branch => 0.14 stable branch
2014-05-31 20:08 neil Resolution open => done
2014-05-31 20:08 neil Assigned To => neil
2014-06-04 12:30 bemyak Note Added: 0026381


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker