Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008587 [DCSS] Bug Report minor always 2014-05-23 17:11 2014-11-01 17:59
Reporter acwest View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008587: Crash on entering Abyss:3 and on subsequent loads
Description Crash morgue: http://dobrazupa.org/morgue/acwest/crash-acwest-20140523-150937.txt [^]

Game crashed on attempt to go from Abyss:2 to Abyss:3. It crashes on every subsequent load attempt.

Perhaps the game is trying to tell me something...
Additional Information
Tags crash
Attached Files

- Relationships
related to 0008584resolvedsgrunt Gozag gold detection still shows items 

-  Notes
(0026255)
neil (administrator)
2014-05-23 17:21

Save here: http://dobrazupa.org/saves/acwest.cs [^]

It seems to be something to do with Gozag gold detection: (39, 39) has no item according to map_knowledge, yet does have the 'detected item' flag.
(0026258)
sgrunt (administrator)
2014-05-23 22:00

0.15-a0-991-gb5a4d5e will let you load your game again; 0.15-a0-993-gdf56bc9 may have fixed the underlying crash, but I'll need to test further.
(0027619)
sgrunt (administrator)
2014-11-01 17:59

I think it's safe to say by now that this is working fine.

- Issue History
Date Modified Username Field Change
2014-05-23 17:11 acwest New Issue
2014-05-23 17:18 acwest Tag Attached: crash
2014-05-23 17:21 neil Note Added: 0026255
2014-05-23 21:37 sgrunt Relationship added related to 0008584
2014-05-23 22:00 sgrunt Note Added: 0026258
2014-05-23 22:00 sgrunt Assigned To => sgrunt
2014-05-23 22:00 sgrunt Status new => assigned
2014-11-01 17:59 sgrunt Note Added: 0027619
2014-11-01 17:59 sgrunt Status assigned => resolved
2014-11-01 17:59 sgrunt Resolution open => done
2014-11-01 17:59 sgrunt Fixed in Branch => 0.15 prerelease branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker