Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008580 [DCSS] Bug Report crash always 2014-05-21 01:28 2014-08-15 06:33
Reporter ActinalWhomp View Status public  
Assigned To doy
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008580: Crash when loading character from dump file in wizmode
Description When in wizmode I attempt to load a char dump and the game crashes with the message

"ASSERT(queue.size() == (unsigned)EXCERSIZE_QUEUE_SIZE) in 'skills.cc' at line 279 failed."

The error seems to be independent of what I'm actually trying to load. It crashes regardless of what I type at the prompt after "&#". I've tried loading from a different character and it still crashed.
Additional Information
Tags No tags attached.
Attached Files txt file icon crash-WizTest2-20140520-192752.txt [^] (6,334 bytes) 2014-05-21 01:28 [Show Content]
? file icon 0001-Gives-error-when-loading-from-nonexistent-file.patch [^] (1,140 bytes) 2014-05-23 20:19 [Show Content]

- Relationships

-  Notes
(0026256)
ActinalWhomp (reporter)
2014-05-23 20:20

This problem was partly my fault. I hadn't realized that:
a) I had to include the file extension.
b) It looks for the files in the main crawl directory not in the morgue as I had assumed.

That said, the game crashes when the file provided is either not existent or exists but isn't a properly formatted character dump. I believe that the patch I uploaded fixes the first of these two cases. However, I'm not familiar with c++/git/large projects so it may well be complete nonsense.
(0026527)
neil (administrator)
2014-06-15 20:39
edited on: 2014-06-15 20:41

I refactored a bit and moved the check earlier than you had put it; and committed the updated version to trunk: 0.15-a0-1530-g7c6d89d . Thanks!

I also made crawl search in the morgue directory if the file wasn't found in the current directory: 0.15-a0-1531-g1f557d6

Leaving this bug open because giving a bad file (or even one with a missing Skills: block) still causes a crash.

(0027019)
doy (developer)
2014-08-15 06:33

Fixed in 717a8ea.

- Issue History
Date Modified Username Field Change
2014-05-21 01:28 ActinalWhomp New Issue
2014-05-21 01:28 ActinalWhomp File Added: crash-WizTest2-20140520-192752.txt
2014-05-23 20:19 ActinalWhomp File Added: 0001-Gives-error-when-loading-from-nonexistent-file.patch
2014-05-23 20:20 ActinalWhomp Note Added: 0026256
2014-06-15 20:39 neil Note Added: 0026527
2014-06-15 20:39 neil Note Edited: 0026527
2014-06-15 20:41 neil Note Edited: 0026527
2014-08-15 06:33 doy Note Added: 0027019
2014-08-15 06:33 doy Status new => resolved
2014-08-15 06:33 doy Fixed in Branch => 0.16 development branch
2014-08-15 06:33 doy Resolution open => done
2014-08-15 06:33 doy Assigned To => doy


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker