Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008577 [DCSS] Bug Report crash always 2014-05-19 23:52 2014-07-03 22:08
Reporter dcl View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008577: Human hunter crash
Description On startup if you select Human, then Hunter, the game crashes. Repeatable. If you start choosing another type (say Human, Beserker), then back up to Human, and select Hunter, the crash does not happen.
Additional Information
Tags No tags attached.
Attached Files txt file icon crash--20140519-164426.txt [^] (4,643 bytes) 2014-05-19 23:52 [Show Content]

- Relationships
has duplicate 0008754closedneil Crash after choosing race and class in Windows Tiles version 
has duplicate 0006357closedneil After character death, new random viable causes CTD. 
has duplicate 0007326closedneil Crash starting a new game. 
has duplicate 0007131resolvedPleasingFungus Incompatible weapon, DjAM 

-  Notes
(0026483)
neil (administrator)
2014-06-14 01:15

Probably fixed in trunk (0.15-a0-1489-g4ea94c4). I suspect you have set the "weapon" option, and hunter was aborting because that wasn't a ranged weapon. Now an incompatible weapon option will just be ignored, instead of exiting.

Thanks!
(0026678)
neil (administrator)
2014-07-03 22:08

Fix ported to stable (0.14.1-25-g305bacd).

- Issue History
Date Modified Username Field Change
2014-05-19 23:52 dcl New Issue
2014-05-19 23:52 dcl File Added: crash--20140519-164426.txt
2014-06-14 01:15 neil Note Added: 0026483
2014-06-14 01:15 neil Status new => resolved
2014-06-14 01:15 neil Fixed in Branch => 0.15 development branch
2014-06-14 01:15 neil Resolution open => done
2014-06-14 01:15 neil Assigned To => neil
2014-07-03 22:04 neil Relationship added has duplicate 0008754
2014-07-03 22:08 neil Note Added: 0026678
2014-07-03 22:08 neil Fixed in Branch 0.15 development branch => 0.14 stable branch
2014-08-15 00:02 neil Relationship added has duplicate 0006357
2014-08-15 00:02 neil Relationship added has duplicate 0007326
2014-08-30 19:02 PleasingFungus Relationship added has duplicate 0007131


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker