Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008565 [DCSS] Upload: Maps and Vaults feature N/A 2014-05-17 06:03 2014-06-20 03:34
Reporter infiniplex View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008565: New city-like layout
Description Here is a layout I had kicking around. It makes a city layout using recursive-division logic like in layout_dis.

It is as a file instead of a patch because my local branch is so far out of date that I don't know what would happen if I updated it. So I am submitting this first.
Additional Information
Tags No tags attached.
Attached Files txt file icon layout_onion_city.txt [^] (5,062 bytes) 2014-05-17 06:03 [Show Content]
png file icon onion-city-layouts.png [^] (20,845 bytes) 2014-05-17 06:03


? file icon 0001-Add-LUA-function-to-find-areas-around-primary-vault.patch [^] (9,079 bytes) 2014-06-20 01:58 [Show Content]
? file icon layout_onion_city.des [^] (6,854 bytes) 2014-06-20 01:59 [Show Content]
png file icon onion-city-layouts2.png [^] (23,486 bytes) 2014-06-20 01:59


? file icon layout_onion_city2.des [^] (6,861 bytes) 2014-06-20 02:06 [Show Content]

- Relationships

-  Notes
(0026188)
infiniplex (reporter)
2014-05-17 06:06

At deeper depths:
-> fewer boxes
-> boxes are more likely to nest 1-for-1
-> hallways are wider

However, these are not very noticeable at this level. Would increasing them be good?
(0026218)
sgrunt (administrator)
2014-05-19 21:29

This ends up looking pretty bad with the tendency of Depths to place a large number of vaults/minivaults. Would there be a reasonable way to get the layout to at least avoid placing rooms on primary vaults (which will be masked appropriately at the time the layout is generating)?
(0026219)
infiniplex (reporter)
2014-05-20 00:33

Best option: Ignore this for now. I will come back to it after I am done my current project of redoing layout weights and branch placement.

I can make it place around primary vaults, most vaults are not primary vaults, so this is of limited value. AFAIK, the Zot entry is the only primary vault in Depths.

Alternatively, this could go somewhere else. Both of layout_chaotic_city and layout_irregular_city place around primary vaults, so they could go in Depths if a city layout is needed there. Or Depths might be better off without one because they are too "fragile".
(0026259)
sgrunt (administrator)
2014-05-23 22:57

Every level in Depths except :1 places a primary vault of some point, so this would still be relevant.
(0026292)
infiniplex (reporter)
2014-05-27 23:28

Interesting.
(0026563)
infiniplex (reporter)
2014-06-20 02:04
edited on: 2014-06-20 02:07

Here is a revised version that places in Elf and Pan. There is a placeholder for it in builder/layout_city.des.

The patch adds 2 functions for LUA. One in C++ and one in dlua/layouts that calls the C++ one. These functions are used to place a layout around a primary vault.

The layout works well in Elf (the ugly vault in the first image is non-primary). In Pan, it does not work as well. However, this is because the Pan rune vaults are not primary vaults. If they are placed as primary vaults (using wizmode commands), the problem disappears. Therefore, the layout adapts to them as well as possible.

EDIT: I found a minor omission in the second layout_onion_city and have uploaded a new one. I can't delete the second one myself.

(0026564)
sgrunt (administrator)
2014-06-20 03:20

Actually, Pan demon vaults are supposed to be primary vaults; there's just a hiccup in the level generation specific to Pan that makes them not so which I just discovered. I'm going to fix that hiccup in a moment and see how this looks.
(0026566)
sgrunt (administrator)
2014-06-20 03:34

Bug fixed and layout landed. Thanks!

- Issue History
Date Modified Username Field Change
2014-05-17 06:03 infiniplex New Issue
2014-05-17 06:03 infiniplex File Added: layout_onion_city.txt
2014-05-17 06:03 infiniplex File Added: onion-city-layouts.png
2014-05-17 06:06 infiniplex Note Added: 0026188
2014-05-19 21:29 sgrunt Note Added: 0026218
2014-05-20 00:33 infiniplex Note Added: 0026219
2014-05-23 22:57 sgrunt Note Added: 0026259
2014-05-27 23:28 infiniplex Note Added: 0026292
2014-06-20 01:58 infiniplex File Added: 0001-Add-LUA-function-to-find-areas-around-primary-vault.patch
2014-06-20 01:59 infiniplex File Added: layout_onion_city.des
2014-06-20 01:59 infiniplex File Added: onion-city-layouts2.png
2014-06-20 02:04 infiniplex Note Added: 0026563
2014-06-20 02:05 infiniplex Note Edited: 0026563
2014-06-20 02:06 infiniplex File Added: layout_onion_city2.des
2014-06-20 02:07 infiniplex Note Edited: 0026563
2014-06-20 03:20 sgrunt Note Added: 0026564
2014-06-20 03:34 sgrunt Note Added: 0026566
2014-06-20 03:34 sgrunt Assigned To => sgrunt
2014-06-20 03:34 sgrunt Status new => resolved
2014-06-20 03:34 sgrunt Resolution open => done
2014-06-20 03:34 sgrunt Fixed in Branch => 0.15 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker