Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008549 [DCSS] Bug Report crash unable to reproduce 2014-05-12 20:02 2014-08-15 20:40
Reporter netkitten View Status public  
Assigned To doy
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0008549: lugonu corruption crashed the game in menkaure sprint
Description i used lugonu corruption in the area with a lot of doors and lava around (to kill mutagenic eyes) and it crashed the game.

sequell tracked it as:
ERROR in 'cloud.cc' at line 359: cloud black smoke in closed door at (68,27) (D)

on reconnect i was put several rooms behind, got invisibility which i had back then when i cleared that room, all monsters on the map were revived and put to sleep and my character shared the same tile with an unique, sonja, i.e. when i stepped from it there was sleeping sonja there. it's probably a separate issue how sprint handles crashes though

i tried to replicate the bug but the next corruption at the roughly the same place went properly

p.s. there was a third issue which is not a bug by itself but imo a design flaw, i.e. that it seems to me it's theoretically possible to be closed with corruption not having a way to leave some area, my successful corruption barred the corridor which was my only way back, even though it left me a theoretical possibility to leave the enclosed area...
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026153)
netkitten (reporter)
2014-05-12 20:05

oh, i forgot to add the game id, it's cirno:cszo:20140412155942s
(0026156)
netkitten (reporter)
2014-05-13 00:39

crashed another game with the same ability again, used it at another place, that time i landed into one of the mutagenic eyes...
(0027024)
doy (developer)
2014-08-15 20:40

Fixed in 0d61daa, thanks!

- Issue History
Date Modified Username Field Change
2014-05-12 20:02 netkitten New Issue
2014-05-12 20:05 netkitten Note Added: 0026153
2014-05-13 00:39 netkitten Note Added: 0026156
2014-08-15 20:40 doy Note Added: 0027024
2014-08-15 20:40 doy Status new => resolved
2014-08-15 20:40 doy Fixed in Branch => 0.16 development branch
2014-08-15 20:40 doy Resolution open => done
2014-08-15 20:40 doy Assigned To => doy


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker