Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008543 [DCSS] Bug Report minor have not tried 2014-05-11 19:27 2014-05-28 06:36
Reporter HilariousDeathArtist View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.15 ancient branch
Summary 0008543: Vault Warden locked himself away due to translucent wall
Description Attached screenshot as it illustrates the issue better than I can describe.

The vault warden was in a room by himself, and I on the other side of the door. The warden locked himself inside the room and me outside, presumably because of the translucent wall next to the door.
Additional Information
Tags No tags attached.
Attached Files png file icon WardenVisionBug.png [^] (498,982 bytes) 2014-05-11 19:27

- Relationships

-  Notes
(0026140)
neil (administrator)
2014-05-11 19:45

This is a result of using tension to decide whether to close the door, which uses LOS_DEFAULT rather than LOS_NO_TRANS.

Probably there's no reason for monsters behind glass to increase tension.
(0026296)
neil (administrator)
2014-05-28 06:36
edited on: 2014-05-28 06:36

Fixed in trunk (0.15-a0-1095-g6a27ad6), by making tension ignore monsters behind glass. Thanks!


- Issue History
Date Modified Username Field Change
2014-05-11 19:27 HilariousDeathArtist New Issue
2014-05-11 19:27 HilariousDeathArtist File Added: WardenVisionBug.png
2014-05-11 19:45 neil Note Added: 0026140
2014-05-28 06:36 neil Note Added: 0026296
2014-05-28 06:36 neil Status new => resolved
2014-05-28 06:36 neil Fixed in Branch => 0.15 development branch
2014-05-28 06:36 neil Resolution open => done
2014-05-28 06:36 neil Assigned To => neil
2014-05-28 06:36 neil Note Edited: 0026296


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker