Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0008542 [DCSS] Bug Report minor always 2014-05-11 18:48 2014-11-05 18:07
Reporter Kvaak View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0008542: Casting bolt spells at a tree can erroneously warn the player about bolt bouncing
Description Attempting to cast bolt spells at a tree will warn the player about the bouncing bolt as if the tree didn't exist, i.e. there's reflective material behind the tree and you'd get hit if the tree didn't eat the bolt instead. Basically this means lightning bolt on most walls and green crystal for all the spells that bounce off it.

Attached screenshot shows how zapping in the green crystal wall's direction warns you about the bouncing bolt despite the fact you will not get hit as long as the tree is there.
Additional Information
Tags No tags attached.
Attached Files png file icon bug2.png [^] (28,283 bytes) 2014-05-11 18:48

- Relationships

-  Notes
(0026141)
neil (administrator)
2014-05-11 19:47

The tracer case of bolt::affect_wall only finishes the beam if it cannot affect the wall. Probably instead it should finish all beams other than digging, as that is the only one that can affect a wall and keep going.
(0026142)
neil (administrator)
2014-05-11 19:49

Also, bolt::affects_wall returns MB_MAYBE for penetrating beams that aren't super-hot that encounter trees. AFAIK these are always stopped, so I'm not sure why it shouldn't return MB_FALSE instead (in which case, it could just return a bool).
(0027254)
wheals (administrator)
2014-09-14 20:52

Should be fixed in 5ac967ef1e1c4. (Not cherry-picking since it's so minor and any small change in the beam code can cause lots of new bugs.)

- Issue History
Date Modified Username Field Change
2014-05-11 18:48 Kvaak New Issue
2014-05-11 18:48 Kvaak File Added: bug2.png
2014-05-11 19:47 neil Note Added: 0026141
2014-05-11 19:49 neil Note Added: 0026142
2014-09-14 20:52 wheals Note Added: 0027254
2014-09-14 20:52 wheals Status new => resolved
2014-09-14 20:52 wheals Fixed in Branch => 0.16 development branch
2014-09-14 20:52 wheals Resolution open => done
2014-09-14 20:52 wheals Assigned To => wheals
2014-11-05 18:06 Kvaak Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker